Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

JavaScript issue

  • 4 uphendule
  • 64 zinale nkinga
  • 40 views
  • Igcine ukuphendulwa ngu cor-el

more options

I'm using Firefox 26.0, and now when I try to log in to Gmail, it shows "JavaScript must be enabled in order for you to use Gmail in standard view. However, it seems JavaScript is either disabled or not supported by your browser. To use standard view, enable JavaScript by changing your browser options, then try again."

I went through all the tabs under "Options" but still can't find a way to solve the issue. Please HELP!!!

Isisombululo esikhethiwe

Hello,

In Firefox 23, as part of an effort to simplify the Firefox options set and protect users from unintentially damaging their Firefox, the option to disable JavaScript was removed from the Firefox Options window.

However, the option to disable JavaScript was not removed from Firefox entirely. You can still access it from about:config or by installing an add-on.

about:config

  1. In the address bar, type "about:config" (with no quotes), and press Enter.
  2. Click "I'll be careful, I promise"
  3. In the search bar, search for "javascript.enabled" (with no quotes).
  4. Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now disabled.

To Re-enable JavaScript, repeat these steps.

Add-ons

You can alternatively install an add-on that lets you disable JavaScript, such as

  • No-Script (to disable JavaScript on a per page basis, as required)
  • QuickJava (to easily disable and enable JavaScript, automatic loading of images, and other content)
  • SettingSanity (adds back removed options for JavaScript, Advanced JavaScript Settings, loading images, and showing the Tab Bar)

Thank you and I hope this helps!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 20

All Replies (4)

more options

Isisombululo Esikhethiwe

Hello,

In Firefox 23, as part of an effort to simplify the Firefox options set and protect users from unintentially damaging their Firefox, the option to disable JavaScript was removed from the Firefox Options window.

However, the option to disable JavaScript was not removed from Firefox entirely. You can still access it from about:config or by installing an add-on.

about:config

  1. In the address bar, type "about:config" (with no quotes), and press Enter.
  2. Click "I'll be careful, I promise"
  3. In the search bar, search for "javascript.enabled" (with no quotes).
  4. Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now disabled.

To Re-enable JavaScript, repeat these steps.

Add-ons

You can alternatively install an add-on that lets you disable JavaScript, such as

  • No-Script (to disable JavaScript on a per page basis, as required)
  • QuickJava (to easily disable and enable JavaScript, automatic loading of images, and other content)
  • SettingSanity (adds back removed options for JavaScript, Advanced JavaScript Settings, loading images, and showing the Tab Bar)

Thank you and I hope this helps!

more options

Thanks a million!!!

more options

It's absurd that one has to enter the Firefox settings for this. I

more options

JavaScript can only be disabled this way if you have done this in a previous Firefox version that still had this setting in the user interface (Tools > Options > Content) or have been using an extension that has done this. JavaScript is enabled by default.

Make sure that JavaScript is enabled (javascript.enabled should be true) and isn't blocked by an extension or otherwise.