X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Gmail says javascript must be enabled on my Mac and I can't figure out how to do that.

Kuphostiwe

I have a Mac and have Firefox 43.0.4 for my browser. I couldn't get an interactive website to work so did something with javascript. It was the wrong thing to do.

Gmail msg says: "JavaScript must be enabled in order for you to use Gmail in standard view. However, it seems JavaScript is either disabled or not supported by your browser. To use standard view, enable JavaScript by changing your browser options, then try again."

Somehow I ended up disabling javascript and now can't reactivate it. I need help as non of the sites are working now.

Thanks.

I have a Mac and have Firefox 43.0.4 for my browser. I couldn't get an interactive website to work so did something with javascript. It was the wrong thing to do. Gmail msg says: "JavaScript must be enabled in order for you to use Gmail in standard view. However, it seems JavaScript is either disabled or not supported by your browser. To use standard view, enable JavaScript by changing your browser options, then try again." Somehow I ended up disabling javascript and now can't reactivate it. I need help as non of the sites are working now. Thanks.

Isisombululo esikhethiwe

If javascript.enabled is true then JavaScript should work on web pages unless you have an extension that blocks JavaScript.

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from websites that cause problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

Don't know

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/601.3.9 (KHTML, like Gecko) Version/9.0.2 Safari/601.3.9

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4265 izisombululo 59803 izimpendulo
Kuphostiwe

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' -------------- Go to the web page. Once the page is loading, mouse to the address bar and '''Left''' click the icon. A window for displaying site information should come up. Select '''More Information.''' Now select '''Permissions.''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow.'''

Umnikazi wombuzo

When I got to the plugins javascript was set to always activate. Then I clicked on one of the other menu choices, came back to plugins and javascript wasn't there.

There was one plugin w/o a name but looks like it was for Facebook when I clicked on more information.

When I got to the plugins javascript was set to always activate. Then I clicked on one of the other menu choices, came back to plugins and javascript wasn't there. There was one plugin w/o a name but looks like it was for Facebook when I clicked on more information.
FredMcD
  • Top 10 Contributor
4265 izisombululo 59803 izimpendulo
Kuphostiwe
https://support.mozilla.org/en-US/kb/javascript-settings-for-interactive-web-pages I've called the big guys to help you. Good luck.

Umnikazi wombuzo

Thank you!

Thank you!
cor-el
  • Top 10 Contributor
  • Moderator
17564 izisombululo 158858 izimpendulo
Kuphostiwe

You can check that JavaScript is enabled and isn't blocked.

  • javascript.enabled should be true on the about:config page

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

See also NoScript.

You can check that JavaScript is enabled and isn't blocked. *javascript.enabled should be true on the <b>about:config</b> page *http://kb.mozillazine.org/JavaScript *https://support.mozilla.org/kb/JavaScript You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config See also NoScript. *https://addons.mozilla.org/firefox/addon/noscript/

Umnikazi wombuzo

Javascript on about:config is false.

But I can't find javascript on about:addons.

Javascript on '''about:config''' is false. But I can't find javascript on '''about:addons'''.
cor-el
  • Top 10 Contributor
  • Moderator
17564 izisombululo 158858 izimpendulo
Kuphostiwe

JavaScript is built-in and not an extension. You need to set javascript.enabled to true to enable JavaScript. If the current value is false then double-click the javascript.enabled line.

JavaScript is built-in and not an extension. You need to set javascript.enabled to true to enable JavaScript. If the current value is false then double-click the javascript.enabled line.

Umnikazi wombuzo

I double-clicked on javascript.enabled and it now reads true.

I still get this msg, "JavaScript must be enabled in order for you to use Gmail in standard view. However, it seems JavaScript is either disabled or not supported by your browser. To use standard view, enable JavaScript by changing your browser options, then try again."

I double-clicked on javascript.enabled and it now reads true. I still get this msg, "JavaScript must be enabled in order for you to use Gmail in standard view. However, it seems JavaScript is either disabled or not supported by your browser. To use standard view, enable JavaScript by changing your browser options, then try again."
cor-el
  • Top 10 Contributor
  • Moderator
17564 izisombululo 158858 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

If javascript.enabled is true then JavaScript should work on web pages unless you have an extension that blocks JavaScript.

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from websites that cause problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
If javascript.enabled is true then JavaScript should work on web pages unless you have an extension that blocks JavaScript. You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and remove cookies from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from websites that cause problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes