Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Bookmarks no longer show in the toolbar. Toolbar is open and blank.

  • 1 baphendule
  • 1 inale nkinga
  • 371 views
  • Igcine ukuphendulwa ngu cor-el

more options

Bookmarks show up under "Bookmarks Toolbar" when I open"Show all Bookmarks" in Library. How do I get them to show in toolbar?

Ama-screenshot ananyekiwe

All Replies (1)

more options

Make sure toolbars like the "Bookmarks Toolbar" are visible. Open the Customize window and set what toolbars (Show/Hide Toolbars) and toolbar items to display.

  • Right-click empty toolbar area -> Customize
  • "3-bar" menu button -> Customize
  • View -> Toolbars
  • check that "Bookmarks Toolbar Items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar Items" is not on the Bookmarks Toolbar then drag it back from the Customize palette to the Customize window to the Bookmarks Toolbar
  • if missing items are in the Customize palette then drag them back from the Customize window to the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button in the Customize palette window to restore the default toolbar set.

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

In case errors are reported with "Verify Integrity" close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.