Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable middle click tab bar

  • 6 uphendule
  • 1 inale nkinga
  • 702 views
  • Igcine ukuphendulwa ngu ZetiX

more options

My previous question: https://support.mozilla.org/en-US/questions/1254024

With the latest update, the following css tweak to disable the creation of new tab when middle clicking the empty tab bar area no longer works.

https://pastebin.com/zSJYR8PJ

This along with the shortcut CTRL+SHIFT+P to open a new private window are features no other browsers have.

Okulungisiwe ngu ZetiX

Isisombululo esikhethiwe

Hmm, still works for me, except the new tab + button wasn't working so I had to change its selector:

/* Block middle-click on tab bar */
#tabbrowser-tabs .arrowscrollbox-scrollbox {
  pointer-events: none;
}
/* Exceptions: tabs, new tab button */
.tabbrowser-tab, #tabs-newtab-button {
  pointer-events: auto !important;
}

This was in a new Firefox profile on Windows, so no title bar, no menu bar, tabs on top, etc.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Isisombululo Esikhethiwe

Hmm, still works for me, except the new tab + button wasn't working so I had to change its selector:

/* Block middle-click on tab bar */
#tabbrowser-tabs .arrowscrollbox-scrollbox {
  pointer-events: none;
}
/* Exceptions: tabs, new tab button */
.tabbrowser-tab, #tabs-newtab-button {
  pointer-events: auto !important;
}

This was in a new Firefox profile on Windows, so no title bar, no menu bar, tabs on top, etc.

more options

My bad, you're correct that it only stops the new tab button from working. I was really frustrated when posting this as I had to remove the css tweak from every device thinking it wouldn't work.

Thank you so much for resolving this!

more options

This might be better code to allow a long press on the new tab button (containers tabs menu), otherwise you can't click an item in this drop-down menu.

/* TAB - Pointer Events */
#tabbrowser-tabs .arrowscrollbox-scrollbox{pointer-events: none}
.tabbrowser-tab,
#tabs-newtab-button,
.tabs-newtab-button,
.new-tab-popup, .new-tab-popup > *{pointer-events: auto}
more options

Sorry for replying to this post again but is there another workaround for disabling this function or where the documentation for the tab bar CSS is?

more options

There appears to have been a change in Firefox 71 for the selector. I hardly use middle-click in that area, so I hadn't noticed it.


/* TAB - Pointer Events [tested:68-73] */
#tabbrowser-tabs :-moz-any(.arrowscrollbox-scrollbox, .tabbrowser-arrowscrollbox) {pointer-events: none}
.tabbrowser-tab, #tabs-newtab-button, .tabs-newtab-button {pointer-events: auto}
.scrollbutton-up, .scrollbutton-down {pointer-events:auto !important}
.new-tab-popup, .new-tab-popup > * {pointer-events: auto}  /*container tabs - longpress*/

Okulungisiwe ngu cor-el

more options

cor-el said

There appears to have been a change in Firefox 71 for the selector. I hardly use middle-click in that area, so I hadn't noticed it.

Can I just say I love you so much. I really cannot use Firefox without this tweak and it's been driving me nuts each time it breaks. Thank you so much!