X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

FF won't open maximized on mon2 when mon1 is fullscreen

Kuphostiwe

Using Win10 and FF 68.0.2

I have two taskbar menu shortcuts, one opens FF maximized on monitor1, the other opens FF maximized on monitor2. They work correctly.

BUT, when I am watching a video on monitor1 in FF fullscreen mode and then I click the shortcut to open a second instance of FF maximized on monitor2, that second instance always opens non-maximized. Its as though FF realizes that it has an instance open in full screen mode and that's why it opens the next instance in non-maximized mode. I am hoping someone can tell me how to have the second instance override this behavior so it will open maximized on monitor2 like it always does. Thanks.

EDIT: When I say fullscreen I was referring to a browser video being played full screen, although the issue is the same when using the normal F11 full screen and there is no video.

Using Win10 and FF 68.0.2 I have two taskbar menu shortcuts, one opens FF maximized on monitor1, the other opens FF maximized on monitor2. They work correctly. BUT, when I am watching a video on monitor1 in FF fullscreen mode and then I click the shortcut to open a second instance of FF maximized on monitor2, that second instance always opens non-maximized. Its as though FF realizes that it has an instance open in full screen mode and that's why it opens the next instance in non-maximized mode. I am hoping someone can tell me how to have the second instance override this behavior so it will open maximized on monitor2 like it always does. Thanks. EDIT: When I say fullscreen I was referring to a browser video being played full screen, although the issue is the same when using the normal F11 full screen and there is no video.

Okulungisiwe ngu johnohh

Isisombululo esikhethiwe

I think I got it fixed, sort of. FF appears to consider everything that's on my one toolbar to be a part of the navbar, since even though the chevron results in showing more bookmarks (and my css code to disable the show more bookmarks chevron does nothing), the code below does make the chevron disappear from the maximized window. Its still there when I am non-maximized but that's okay as long as it disappears when I maximize. So, good to go for now.. Thanks

  1. pageActionButton { display: none !important; }
Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

ublock origin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8695 izisombululo 71076 izimpendulo
Kuphostiwe

Hi johnohh, when you're in fullscreen and you press Ctrl+n to launch a new window, it opens as a resizable window, even if the fullscreen window was maximized before and after you enter/exit fullscreen, and even though normally Ctrl+n in a maximized window opens a new maximized window.

All of which is just to say that what you are seeing is consistent with how Firefox is designed, and the Windows shortcut setting apparently doesn't make any difference.

I'm not aware of a workaround, but then, I haven't searched. Maybe you can find something out there?

Hi johnohh, when you're in fullscreen and you press Ctrl+n to launch a new window, it opens as a resizable window, even if the fullscreen window was maximized before and after you enter/exit fullscreen, and even though normally Ctrl+n in a maximized window opens a new maximized window. All of which is just to say that what you are seeing is consistent with how Firefox is designed, and the Windows shortcut setting apparently doesn't make any difference. I'm not aware of a workaround, but then, I haven't searched. Maybe you can find something out there?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

jscher2000 said

Hi johnohh, when you're in fullscreen and you press Ctrl+n to launch a new window, it opens as a resizable window, even if the fullscreen window was maximized before and after you enter/exit fullscreen, and even though normally Ctrl+n in a maximized window opens a new maximized window. All of which is just to say that what you are seeing is consistent with how Firefox is designed, and the Windows shortcut setting apparently doesn't make any difference. I'm not aware of a workaround, but then, I haven't searched. Maybe you can find something out there?

Hey thanks for getting back to me. Maybe if I tell you the broader issue you might have an idea or two for me to try.

I've modified my chrome.css to create a single, dense toolbar combining the menu bar, url bar, and bookmarks toolbar. When I open FF maximized the "1" section of the attached pic is how it looks, which I like. And when FF is open non-maximized, the "show more bookmarks" chevron appears since there is not room for all the bookmarks (section 2 of pic). Its not a big deal since I only use maximized windows. BUT, when the non-maximized windows is THEN maximized, that dang chevron just stays there and bugs me even though its no longer needed (section 3 of pic).

So if I could find a way to get rid of the chevron altogether, I would be all set.

''jscher2000 [[#answer-1246666|said]]'' <blockquote> Hi johnohh, when you're in fullscreen and you press Ctrl+n to launch a new window, it opens as a resizable window, even if the fullscreen window was maximized before and after you enter/exit fullscreen, and even though normally Ctrl+n in a maximized window opens a new maximized window. All of which is just to say that what you are seeing is consistent with how Firefox is designed, and the Windows shortcut setting apparently doesn't make any difference. I'm not aware of a workaround, but then, I haven't searched. Maybe you can find something out there? </blockquote> Hey thanks for getting back to me. Maybe if I tell you the broader issue you might have an idea or two for me to try. I've modified my chrome.css to create a single, dense toolbar combining the menu bar, url bar, and bookmarks toolbar. When I open FF maximized the "1" section of the attached pic is how it looks, which I like. And when FF is open non-maximized, the "show more bookmarks" chevron appears since there is not room for all the bookmarks (section 2 of pic). Its not a big deal since I only use maximized windows. BUT, when the non-maximized windows is THEN maximized, that dang chevron just stays there and bugs me even though its no longer needed (section 3 of pic). So if I could find a way to get rid of the chevron altogether, I would be all set.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8695 izisombululo 71076 izimpendulo
Kuphostiwe

Impendulo Ewusizo

The overflow icon is a hard problem to solve when you have the Bookmarks Toolbar Item on the main toolbar because then you have double-overflow situation. I've seen it discussed, but I don't know of a solution for that.

The overflow icon is a hard problem to solve when you have the Bookmarks Toolbar Item on the main toolbar because then you have double-overflow situation. I've seen it discussed, but I don't know of a solution for that.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Isisombululo Esikhethiwe

I think I got it fixed, sort of. FF appears to consider everything that's on my one toolbar to be a part of the navbar, since even though the chevron results in showing more bookmarks (and my css code to disable the show more bookmarks chevron does nothing), the code below does make the chevron disappear from the maximized window. Its still there when I am non-maximized but that's okay as long as it disappears when I maximize. So, good to go for now.. Thanks

  1. pageActionButton { display: none !important; }
I think I got it fixed, sort of. FF appears to consider everything that's on my one toolbar to be a part of the navbar, since even though the chevron results in showing more bookmarks (and my css code to disable the show more bookmarks chevron does nothing), the code below does make the chevron disappear from the maximized window. Its still there when I am non-maximized but that's okay as long as it disappears when I maximize. So, good to go for now.. Thanks #pageActionButton { display: none !important; }
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

above, pageActionButton is actually preceded by a pound sign (#) but the forum filter turned it into a 1.

above, pageActionButton is actually preceded by a pound sign (#) but the forum filter turned it into a 1.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17479 izisombululo 157964 izimpendulo
Kuphostiwe

You also seem to have a problem with the window control buttons that overlap items.

.titlebar-buttonbox-container { display:none!important; }

If necessary use the system menu (Alt+Space).

You also seem to have a problem with the window control buttons that overlap items. .titlebar-buttonbox-container { display:none!important; } If necessary use the system menu (Alt+Space).
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

cor-el said

You also seem to have a problem with the window control buttons that overlap items. .titlebar-buttonbox-container { display:none!important; } If necessary use the system menu (Alt+Space).

But I do not want the buttons to disappear altogether. btw that one to the left is the "move window to next monitor" button that is part of DisplayFusion. All four buttons are selectable. Here's a pic.

''cor-el [[#answer-1246709|said]]'' <blockquote> You also seem to have a problem with the window control buttons that overlap items. .titlebar-buttonbox-container { display:none!important; } If necessary use the system menu (Alt+Space). </blockquote> But I do not want the buttons to disappear altogether. btw that one to the left is the "move window to next monitor" button that is part of DisplayFusion. All four buttons are selectable. Here's a pic.

Okulungisiwe ngu johnohh

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

the bugzilla.mozilla.org site has confirmed this as a bug, so perhaps it will be fixed later

https://bugzilla.mozilla.org/show_bug.cgi?id=1575635

the bugzilla.mozilla.org site has confirmed this as a bug, so perhaps it will be fixed later https://bugzilla.mozilla.org/show_bug.cgi?id=1575635
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.