Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox not remembering default .eml opening

  • 7 uphendule
  • 1 inale nkinga
  • 13 views
  • Igcine ukuphendulwa ngu cor-el

more options

When opening .eml files, I configured Firefox to open with Microsoft Outlook. I checked the "Do this automatically for files like this from now on.", but Firefox always prompts. When it prompts, it still has the "Do this automatically" box checked. This appears to only happen with .eml files for me. Other file types automatically launch the configured default program (as expected). Any help would be appreciated.

Thank you, Nathan

Ama-screenshot ananyekiwe

All Replies (7)

more options

Hi llbean911, Is .eml associated with Outlook in your Windows settings? Go to: Settings -> Apps -> Default Apps under the Reset button click on Choose default apps by file type. (It may take a minute to generate the list) Scroll down to .eml

more options

My_Cheese_Is_Slippin',

I just checked and confirmed that Outlook is the default app for .eml files in my Windows (see attached image). That was a very good thought though! Thank you.

Thanks, Nathan

more options

Hi llbean911, This might be a Windows issue.

For example: I have an issue where, when I right-click on an image file and select Send To -> Mail Recipient - it won't work. The "solution" is to remove an Outlook registry entry. I don't have an Outlook registry to remove. The work around is to right-click on the file and select Share.

I know that this is not the exact problem which you are experiencing but, it might be something along those lines.

more options

Another thought. In Firefox Options -> General page -> Applications do you have both eml and mailto set for Outlook?

more options

My_Cheese_Is_Slippin' said

Another thought. In Firefox Options -> General page -> Applications do you have both eml and mailto set for Outlook?

This was a good thought as well! In the General settings, Firefox was set to use the default application (which is Outlook). I changed it to be Outlook specifically (rather than just the default application) for both "mailto" and "eml". I tested and the same thing is happening.

Thank you, Nathan

more options

Just to see what is going on -

I assume that you are here on the website - Right-click on your avatar (or mine) and select Email Image... What appears in the Launch Application window? Is Outlook available?

more options

There are some possible causes for this to happen. The first is that the server doesn't send the file with a valid MIME type for this file extension. You can possibly check this in the Network Monitor.

You can also check the .eml file extension in the handlers.json file in the profile folder. Its action should probably be action:2 or action:4

alwaysAsk = 1;
useHelperApp = 2;
useSystemDefault = 4;

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.