Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

For only ONE website, Firefox autofills only my password but not my login ID

  • 5 uphendule
  • 1 inale nkinga
  • 51 views
  • Igcine ukuphendulwa ngu cor-el

more options

I cannot say whether anything had changed just prior but, beginning a month or two ago, while Firefox saves/autofills my login IDs and passwords for all other websites, it refuses – on ONE website only – to autofill my login ID; it autofills ONLY the password (the login ID happens to be an email address, as is the case on many other sites).

I have checked and re-checked the Logins and Passwords preferences, which has saved the correct login ID and password for this particular site. I have deleted cookies, I have cleared the browser cache.

What else can I check?

I cannot say whether anything had changed just prior but, beginning a month or two ago, while Firefox saves/autofills my login IDs and passwords for all other websites, it refuses – on ONE website only – to autofill my login ID; it autofills ONLY the password (the login ID happens to be an email address, as is the case on many other sites). I have checked and re-checked the Logins and Passwords preferences, which has saved the correct login ID and password for this particular site. I have deleted cookies, I have cleared the browser cache. What else can I check?

All Replies (5)

more options

Hi mike36, You can try Forget About This Site. This will clear out everything in regard to that site, except bookmarks. Delete browsing, search and download history on Firefox Scroll down to 'Remove a single website from your history.'

more options

It is possible that the website has changed the input form (Firefox stores the names of these fields as well, but these aren't exposed).

Did you try to remove this entry and let Firefox save it once again?

You can also first try to type the wrong password to see if that triggers an update request.


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Thanks, guys. But...

As My_Cheese suggested, I tried the 'Remove a single website from your history,' but with no change.

And, as core-el suggested, I did completely remove the entry and had Firefox save it again (did that several times). Typing an incorrect log in or password only generates an error from the website. And, starting in safe mode (I never use any but the default theme), nothing changes. So, I'm going to guess that you may be right: that the website has somehow changed the input form.

And this may be a clue: after having cleared this site from saved logins & passwords and having Firefox save the credentials again, when the Firefox save confirmation window drops down, the first field (user name?) does not automatically populate from the website input form. The password field does; but not the other field.

However: the Firefox Saved Logins file (in Preferences) DOES save the login/email address, but Firefox does not autofill it in the form. Even if I begin typing it.

Okulungisiwe ngu mike36

more options

UPDATE: On the login page in question, Firefox DOES suggest at least two other possible logins (user names) for the field is labeled "Email," but the correct email address (as is saved in Preferences) is not among them.

more options

You can double-click username and password items saved in the Password Manager to edit these items. If necessary then you can use Fill Login and Fill Password in the right-click context menu to make Firefox fill the fields. Best is to create a block exception to prevent Firefox from updating/modifying the password stored in the Password Manager.