X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Why doesn't blocking cookies work

Kuphostiwe

Why does the following happen? Firefox 67.0.4

1) In the options menu I have "Block all third party cookies" as the main option.

2) In "Manage permissions" I have blocked both http://google.com as well as https://google.com.

3) I remove all the cookies with the word "google" in them.

4) I do a single google search.

5) Again, I have 6 cookies set by google. :-(

The same thing seems to be happening with twitter and youtube (normally I don't visit either, but I occasionally unsuspectingly click a link taking me there).

Why does the following happen? Firefox 67.0.4 1) In the options menu I have "Block all third party cookies" as the main option. 2) In "Manage permissions" I have blocked both http://google.com as well as https://google.com. 3) I remove all the cookies with the word "google" in them. 4) I do a single google search. 5) Again, I have 6 cookies set by google. :-( The same thing seems to be happening with twitter and youtube (normally I don't visit either, but I occasionally unsuspectingly click a link taking me there).

Isisombululo esikhethiwe

Hello Jyrki,

Would you try this please :

When you're on (any) google.com site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Block".

Then close and restart Firefox.

Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Eminye Imininingwane

McCoy
  • Top 10 Contributor
464 izisombululo 4230 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Hello Jyrki,

Would you try this please :

When you're on (any) google.com site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Block".

Then close and restart Firefox.

Hello Jyrki, Would you try this please : When you're on (any) google.com site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Block". Then close and restart Firefox.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Initially I was skeptical about this. Indeed, following these instructions showed that the site was already blocked!

However, closing and restarting Firefox. And then testing it s before, revealed that the problem was solved!

My explanation: Earlier I was not aware that for Firefox it makes a difference whether the blocked site is google.com, http://google.com, or https://google.com. I learned about that here on the same day I posted my question. But, after adding the https-version, I DID NOT CLOSE AND RESTART FF, and the problem persisted.

Anyway, the problem seems to be solved now. Thanks, McCoy!

Initially I was skeptical about this. Indeed, following these instructions showed that the site was already blocked! However, closing and restarting Firefox. And then testing it s before, revealed that the problem was solved! My explanation: Earlier I was not aware that for Firefox it makes a difference whether the blocked site is google.com, http://google.com, or https://google.com. I learned about that here on the same day I posted my question. But, after adding the https-version, I DID NOT CLOSE AND RESTART FF, and the problem persisted. Anyway, the problem seems to be solved now. Thanks, McCoy!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
464 izisombululo 4230 izimpendulo
Kuphostiwe

My pleasure, Jyrki. I'm glad you got everything working the way it should - well done !

My pleasure, Jyrki. I'm glad you got everything working the way it should - well done !
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.