Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Vimeo player was working two months ago and now its not, but old vimeo Video's i've watched I can still watch them

  • 11 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu Pj

more options

two months ago i was watching video's on Vimeo player on a browser. Then i installed Windows 7 on my new hard drive and now ALL VIMEO players WILL NOT play on Modzilla. But if i watch an old Vimeo video's that i have watched will play normally.. so what is going on.. why is the NEW modzilla BLOCKING

All Replies (11)

more options

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

well i tried restarting into safe mode, i don't get a window that ask's me if i want to go into safe mode when i click the restart with add-ons disabled. It just restarts modzilla. Now i have tried the other link too and did what it said to try and that too didn't work for me. Still Vimeo will not play any more it just spin's trying to load and never goes anywhere.

more options

now i finally got it into safe mode and still its not working.

more options

Are there media related messages in the Web Console?

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

more options

no i cant post it.. need to sign in.. but i can go to my friend house down the street.. go onto my spare comp with the also a new window 7 install and new modillza and it works just fine.

more options

Did you check the Web Console?

You can open the YouTube test page to check support in Firefox for playing HTML5 media.

more options

it opens to a youtube page where i can read about what support html5 work with and all box's are checked. Im learning this stuff as fast as i can atm, this is all new to me

ive opened the webpage where i have been watching the vimeo vid's, with the web console open this pop's up: Source map error: request failed with status 404 Resource URL: Source Map URL:

and then some info about the video is ready, length and other info and at the end of that is

Use of Mutation Events is deprecated. Use MutationObserver instead. checkout.js:8324:16 Source map error: ReferenceError: WebAssembly is not defined Resource URL: Source Map URL:

this might be more info then needed. sorry if so.

more options

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

im sorry to say but It doesn't seem to be working no matter what i try.

i still see in the console Source map error: ReferenceError: WebAssembly is not defined Resource URL: Source Map URL:

and your "learn more" doesn't really tell you what to do to fix it.. just says there are different types and here are just some of them..
more options

Those messages in the Console aren't related to this issue only media related message matter, so something else must be wrong if you can't play these Vimeo videos.

more options

dirtnap said

Two months ago, I was watching video's on Vimeo player on a browser. Then I installed Windows 7 on my new hard drive and now ALL VIMEO players WILL NOT play on Mozilla. But if I watch old Vimeo videos that I had watched, they will play normally...

Someone will jump in here to help me, but I think it has do with what version of Window 7 did you download? It may not have the proper media/Codecs to play some videos?

Otherwise, try this:

Manage Permissions:

Go to Menu > Options and enter in the Options Search Box, Site Data. Click on Manage Permissions and in there add:

and then again with:

...then Save it.

~Pj (Win7 Pro, Media Center Edition, SP1)