Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I can't specify a website under Camera-Permissions in Settings

  • 9 uphendule
  • 5 zinale nkinga
  • 6709 views
  • Igcine ukuphendulwa ngu McCoy

more options

I want to use my web cam on a certain website. I click on the little information button in the browser window and get sent to Permissions. I click the drop down for camera and get to the "Settings - Camera Permissions" page, where I cannot specify the website to grant permission for the cam to work on the site. I tried to upload a screen shot of that page, but it was unable to upload.

Isisombululo esikhethiwe

hooverjo said

The video feed to the site is a blank screen.

Would you try this please :

Clear the Firefox cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

"Remove the cookies" from websites that cause problems :

https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site")

Does that make a difference  ?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (9)

more options

Here is the page. I type a website address in the box that says "Search Website" and nothing happens when I click the Save button.

I have Firefox set to Private Browsing. I will try it without this setting and update this question if things change.

more options

You should use the standard first before going private. And is your webcam working or did you test it before using this?

more options

I tried standard, with the same result. My camera works on Opera on the site in question.

more options

Hello hooverjo,

The context menu, shown in your screenshot : that is where you remove the site your granted permission for.

I'm not sure if the following is what you did earlier, but just in case you didn't - would you please try this :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to "Page Info". Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Use the Camera". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Does that work  ?

more options

I followed your instructions and the web cam is now recognized under Permissions and the indicator light on it turns green. However, the video feed to the site is a blank screen. I don't have this problem with Opera.

more options

Isisombululo Esikhethiwe

hooverjo said

The video feed to the site is a blank screen.

Would you try this please :

Clear the Firefox cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

"Remove the cookies" from websites that cause problems :

https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site")

Does that make a difference  ?

more options

I followed your instructions and also used CC Cleaner. The camera did not work after rebooting my laptop, despite being recognized and turning on.

I decided to turn off my laptop overnight. This morning the webcam worked immediately! Thanks for your help. I figure that all of this needed to be re-done after the last update, and that my laptop needed 8 hours of rest.

more options

Sometimes it can help to close and restart Firefox or reboot the computer in case other software is using a device.

more options

I just noticed that you marked one of my posts as Chosen Solution, but I didn't really solve your problem though .... (?)

(You can remove that Chosen Solution mark by clicking on the "Undo" button to the right of that post.)