X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Unable to play Netflix video

Kuphostiwe

The issue seems to be with DRM. Although DRM videos play on other sites like on Amazon Prime Video. I've done everything I could find on the internet as to fix this issue like I've checked and unchcecked play DRM content in the settings and cleared cookies and cache and everything but nothing seems to be fixing the issue. Also, everytime I load Netflix I get a little yellow dialogue box saying installing components please try again. This happens everytime I load Netflix. Now when I click on any video it asks me to install SilverLight, I've installed it already but still it asks me to install it to play the video.

The issue seems to be with DRM. Although DRM videos play on other sites like on Amazon Prime Video. I've done everything I could find on the internet as to fix this issue like I've checked and unchcecked play DRM content in the settings and cleared cookies and cache and everything but nothing seems to be fixing the issue. Also, everytime I load Netflix I get a little yellow dialogue box saying installing components please try again. This happens everytime I load Netflix. Now when I click on any video it asks me to install SilverLight, I've installed it already but still it asks me to install it to play the video.

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; rv:62.0) Gecko/20100101 Firefox/62.0

Eminye Imininingwane

FFus3r 50 izisombululo 757 izimpendulo
Kuphostiwe

did you try to restart firefox after installing silverlight ?

did you try to restart firefox after installing silverlight ?

Umnikazi wombuzo

Yeah I've restarted firefox but the same issue persists. Opening Netflix comes up with the yellow box saying installing components please try again later and when trying to play videos it asks to install silverlight.

Yeah I've restarted firefox but the same issue persists. Opening Netflix comes up with the yellow box saying installing components please try again later and when trying to play videos it asks to install silverlight.
FFus3r 50 izisombululo 757 izimpendulo
Kuphostiwe

do you have flash player installed? if yes then do these steps:

  • Click the menu button and choose Plugins.
  • Click More or Options for the Shockwave Flash plugin.
  • Uncheck Enable Adobe Flash protected mode.

Netflix should now play . like the problem with Adobe Flash protected mode.

do you have flash player installed? if yes then do these steps: * Click the menu button and choose Plugins. * Click More or Options for the Shockwave Flash plugin. * Uncheck Enable Adobe Flash protected mode. Netflix should now play . like the problem with Adobe Flash protected mode.

Umnikazi wombuzo

No, I don't have or at least don't see Flashplayer in the plugins section.

No, I don't have or at least don't see Flashplayer in the plugins section.
FFus3r 50 izisombululo 757 izimpendulo
Kuphostiwe

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components. * Options/Preferences -> General: Play DRM * https://support.mozilla.org/en-US/kb/enable-drm

Umnikazi wombuzo

As stated in my first post, I've already done the DRM off/on toggle and that didn't work. Still facing same issues.

As stated in my first post, I've already done the DRM off/on toggle and that didn't work. Still facing same issues.
FFus3r 50 izisombululo 757 izimpendulo
Kuphostiwe

see if the 'always use private browsing' box was checked!.

if yes, then unchecked it.

see if the ''''always use private browsing'''' box was checked!. if yes, then '''unchecked it'''.

Umnikazi wombuzo

Its already unchecked.

Its already unchecked.
FFus3r 50 izisombululo 757 izimpendulo
Kuphostiwe

ok

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your Firefox profile data (such as bookmarks and passwords), since that information is stored in a different location.

To do a clean reinstall of Firefox, please follow these steps: Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

ok Certain Firefox problems can be solved by performing a ''Clean reinstall''. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your [[Profiles - Where Firefox stores your bookmarks, passwords and other user data|Firefox profile]] data (such as bookmarks and passwords), since that information is stored in a different location. To do a clean reinstall of Firefox, please follow these steps: '''Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from [https://www.mozilla.org mozilla.org] (or choose the download for your operating system and language from [https://www.mozilla.org/firefox/all/ this page]) and save the setup file to your computer. #After the download finishes, close all Firefox windows (or open the Firefox menu [[Image:New Fx Menu]] and click the close button [[Image:Close 29]]). #Delete the Firefox installation folder, which is located in one of these locations, by default: #*'''Windows:''' #**C:\Program Files\Mozilla Firefox #**C:\Program Files (x86)\Mozilla Firefox #*'''Mac:''' Delete Firefox from the Applications folder. #*'''Linux:''' If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see [[Installing Firefox on Linux]]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page], simply remove the folder ''firefox'' in your home directory. #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. More information about reinstalling Firefox can be found [[Troubleshoot and diagnose Firefox problems#w_5-reinstall-firefox|here]]. <b>WARNING:</b> Do not use a third party uninstaller as part of this process. Doing so could permanently delete your [[Profiles|Firefox profile]] data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. <u>These cannot be easily recovered unless they have been backed up to an external device!</u> See [[Back up and restore information in Firefox profiles]]. <!-- Starting in Firefox 31, the Firefox uninstaller no longer lets you remove user profile data.Ref: Bug 432017 and https://support.mozilla.org/kb/uninstall-firefox-from-your-computer/discuss/5279 [Fx31] Windows uninstaller will no longer offer the option to remove personal data --> Please report back to say if this helped you! Thank you.

Umnikazi wombuzo

Did as you asked, still facing same issues. Didn't fix the problem.

Did as you asked, still facing same issues. Didn't fix the problem.
FFus3r 50 izisombululo 757 izimpendulo
Kuphostiwe

install Windows Media Pack

install '''Windows Media Pack'''

Umnikazi wombuzo

It says already installed.

It says already installed.
Roland Tanglao
  • Administrator
71 izisombululo 781 izimpendulo
Kuphostiwe

Hi slmnkhan2016

I play Netflix and Amazon Prime Video fine on three Windows 10 computers without Flash or Silverlight installed so there's hope :-)

If you haven't already, please try: 1. Firefox Safe Mode: https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode 2. Refresh Firefox: https://support.mozilla.org/kb/refresh-firefox-reset-add-ons-and-settings

If that doesn't work, then please copy and paste about:support (or help->Troubleshooting information) into this thread please!

Cheers!

...Roland

Hi slmnkhan2016 I play Netflix and Amazon Prime Video fine on three Windows 10 computers without Flash or Silverlight installed so there's hope :-) If you haven't already, please try: 1. Firefox Safe Mode: https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode 2. Refresh Firefox: https://support.mozilla.org/kb/refresh-firefox-reset-add-ons-and-settings If that doesn't work, then please copy and paste about:support (or help->Troubleshooting information) into this thread please! Cheers! ...Roland
vmoutsop 0 izisombululo 9 izimpendulo
Kuphostiwe

I've been having the same problem and have gone through every recommended change, setting and check. I've started in safe mode, shutdown all add-ons, etc. and it doesn't work. This seems to have happened recently. I know in the past couple of months it did work but now since I upgraded to 63.01 it doesn't work.

Any help is appreciated.

I've been having the same problem and have gone through every recommended change, setting and check. I've started in safe mode, shutdown all add-ons, etc. and it doesn't work. This seems to have happened recently. I know in the past couple of months it did work but now since I upgraded to 63.01 it doesn't work. Any help is appreciated.
jscher2000
  • Top 10 Contributor
8575 izisombululo 70112 izimpendulo
Kuphostiwe

Hi vmoutsop, if you check your plugins, do you have Widevine installed and enabled?

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Plugins.

Then check the list on the right side that Widevine has the status "Always Enabled."

Hi vmoutsop, if you check your plugins, do you have '''Widevine''' installed and enabled? * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click '''Plugins'''. Then check the list on the right side that Widevine has the status "Always Enabled."

Okulungisiwe ngu jscher2000

vmoutsop 0 izisombululo 9 izimpendulo
Kuphostiwe

Hi jscher2000, thanks for responding.

Yes, Widevine is set to "Always Activate" and Widevine has a last updated of November 2018.

I also have a portable version running that is still at v63, not 63.01 and it seems to work fine.

When I look at the web console I keep seeing this message:

XML Parsing Error: not well-formed Location: https://www.netflix.com/nq/msl_v1/cadmium/pbo_logblobs/%5E1.0.0/router Line Number 1, Column 1:

Hi jscher2000, thanks for responding. Yes, Widevine is set to "Always Activate" and Widevine has a last updated of November 2018. I also have a portable version running that is still at v63, not 63.01 and it seems to work fine. When I look at the web console I keep seeing this message: XML Parsing Error: not well-formed Location: https://www.netflix.com/nq/msl_v1/cadmium/pbo_logblobs/%5E1.0.0/router Line Number 1, Column 1:
vmoutsop 0 izisombululo 9 izimpendulo
Kuphostiwe

Is there a way to download the about:config and compare it to a fresh config?

That is the only thing I can think that may be different. Maybe I changed something and it's causing a problem.

Is there a way to download the about:config and compare it to a fresh config? That is the only thing I can think that may be different. Maybe I changed something and it's causing a problem.