Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox taking too much time while loading a page

  • 8 uphendule
  • 1 inale nkinga
  • 20 views
  • Igcine ukuphendulwa ngu FredMcD

more options

After the last update Firefox started to lag a lot upon opening pages, and sometimes it doesn't open them at all. I've tried opening in safe mode and refreshing Firefox but none worked.

All Replies (8)

more options

What's your computer system and Firefox version?

Achmedv1 said

I've tried opening in safe mode and refreshing Firefox but none worked.

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

Please note that I am having this problem on several computers not just on a single one, also I can tell it is not a internet issue since other browsers are working perfectly. Also please note that I am working Windows PC's not Linux.

I'll try what you've said and i'll update you with results.

Thank you.

more options

FredMcD said

What's your computer system and Firefox version?

All my PC's have windows 7 installed, having Firefox 61.0.2 64-bit version


FredMcD said

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

I've tried doing that, the same problem persists

more options

Did the problem start with the current Firefox, or what?

Firefox safe mode no help. Computer safe mode no help.

Achmedv1 said

Firefox 61.0.2 64-bit version

Many have reported issues using the 64bit Firefox. Install the 32bit version from; Download Firefox For All languages And Systems {web link}

more options

Apparently switching to 32-bit version solved the problem, I'll try it for a couple of days and update you with the results.

thank you for your support.

more options

Glad to help. Safe Surfing.

more options

FredMcD said

Many have reported issues using the 64bit Firefox. Install the 32bit version from;

Hmm. What do I lose in performance and features if I decide to switch to the 32-bit version? Is it easy enough to go back to 32-Bit without any 'nightmare' install problems?


~Pj

more options

I am not sure. You could post a new question asking.