Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Really? Amazon's website is insecure? You need to look into why you won't let users go there.

  • 17 uphendule
  • 1 inale nkinga
  • 3072 views
  • Igcine ukuphendulwa ngu Em-Ess

more options

Firefox won't let me access Amazon's website. Need to use Chrome. Where do you suppose is the problem, with Amazon or with Firefox?

Isisombululo esikhethiwe

Em-Ess said

To follow up on WestEnd's experience -- and now this really gets weird -- I too had no trouble when I put smile.amazon.com in the address bar. But when I put www.smile.amazon.com (which is how my bookmark reads) I again got the same error message. What do you make of that?

Secure: https://www.smile.amazon.com/ => dead end, unable to connect

Insecure: http://www.smile.amazon.com/ => redirects to https://smile.amazon.com/ap/signin?...

It seems Amazon stopped using www with its Smile domain and may not have properly redirected all of the old addresses.

In the old days, websites would tell you thinks like "Please update your bookmarks"; annoying as that was, at least it gave a hint that your bookmark might have an out-of-date address.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (17)

more options
more options

Now this is interesting. This is the message I get:

Secure Connection Failed. The connection to www.smile.amazon.com was interrupted while the page was loading.
   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

But I only get it when I try to access smile.amazon.com, the version of the website that includes donations to charity. The regular Amazon.com connects without a problem. What can one make of that?

Michael Spielman

more options

I called for more help. What protection programs are you using?

more options

Just whatever is built into a MacBookPro, OS 10.13.4, and Sophos

more options

Try refreshing or re-installing Firefox

more options

Refreshing did nothing and I'm loathe to reinstall so I don't have to worry about my add-ons and everything. By the way, what do I do with the folder that appeared on my desktop after refreshing called "Old Firefox Data"?

And really, you think the problem is at my end and not at Firefox's ?

more options

Refreshing Firefox {web link} is a LAST RESORT ! !

Refreshing Firefox -- easily fix most problems

If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed.


Em-Ess said

By the way, what do I do with the folder that appeared on my desktop after refreshing called "Old Firefox Data"?

During a refresh, data from the old profile is copied to a new profile. The old one is then moved to the Old Firefox folder so that one can recover data from the folder.

more options

Do you get the SEC_ERROR_UNKNOWN_ISSUER error message or something else?

What security software do you have (Kaspersky or AVG/Avast)?

Can you attach a screenshot?


You can check if there is more detail available about the issuer of the certificate.

  • click the "Advanced" button show more detail
  • click the blue SEC_ERROR_UNKNOWN_ISSUER message to show the certificate chain
  • click "Copy text to clipboard" and paste the base64 certificate chain text in a reply

If clicking the SEC_ERROR_UNKNOWN_ISSUER text doesn't provide the certificate chain then try these steps to inspect the certificate.

  • open the Server tab in the Certificate Manager
    • Options/Preferences -> Privacy & Security
      Certificates: View Certificates -> Servers: "Add Exception"
  • paste the URL of the website (https://xxx.xxx) in it's Location field.

Let Firefox retrieve the certificate -> "Get Certificate"

  • click the "View" button and inspect the certificate

You can see detail like the issuer of the certificate and intermediate certificates in the Details tab.

more options

You need to read the whole thread. I have quoted the exact message I get. And again, this is only a problem when I try to go to Amazon smile, not the regular Amazon. AND, I tried it on my wife's laptop which is using an older version of Firefox and there is absolutely no problem.

So again, does anyone think this is MY problem or Firefox's. Clearly it is Firefox's and I have no idea how to get their attention to fix whatever needs to be fixed. In the meantime, I'll just use Chrome.

more options

@Em-Ess, they asked for screenshot of the error not a txt of the error to know what is happening. Your first line response "You need to read the whole thread" comes off as very conceited and is most likely not to get any more help. FYI, this is FF end user forum not like some Official Support Ticket fix-it line.

more options

This is not a Firefox error. You likely have security software that act as a man-in-the-middle and scan the connection and sends its own certificate to Firefox, so Firefox sees the certificate send by this software and not the certificate that the web server sends. Firefox doesn't have the root certificate and thus shows an error.

You can try to set this pref to true on the about:config page to see if that has effect (not sure if this works with the Mac Keychain).

  • security.enterprise_roots.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Well, I will try that. But I have my doubts. Look, this problem only exists at smile.amazon.com, NOT at amazon.com. That certainly sounds like the problem is Firefox's. But I will try. By the way, a screen shot of the error message is below, if that makes a difference.

The main problem is that there is no way to get to anyone at Firefox to raise this issue. That's how it SHOULD be handled, not via a forum.

But I do appreciate all the help.

more options

Have no issue clicking on the smile.amazon.com. To prove it here is the screen shot. Windows 10x64 Pro FF60.0.2x64. So it's not a FF issue as your stating otherwise I would've gotten the same message.

more options

To follow up on WestEnd's experience -- and now this really gets weird -- I too had no trouble when I put smile.amazon.com in the address bar. But when I put www.smile.amazon.com (which is how my bookmark reads) I again got the same error message. What do you make of that?

more options

Isisombululo Esikhethiwe

Em-Ess said

To follow up on WestEnd's experience -- and now this really gets weird -- I too had no trouble when I put smile.amazon.com in the address bar. But when I put www.smile.amazon.com (which is how my bookmark reads) I again got the same error message. What do you make of that?

Secure: https://www.smile.amazon.com/ => dead end, unable to connect

Insecure: http://www.smile.amazon.com/ => redirects to https://smile.amazon.com/ap/signin?...

It seems Amazon stopped using www with its Smile domain and may not have properly redirected all of the old addresses.

In the old days, websites would tell you thinks like "Please update your bookmarks"; annoying as that was, at least it gave a hint that your bookmark might have an out-of-date address.

more options

Em-Ess said

By the way, a screen shot of the error message is below

When you press "Learn More," does it show anything?

more options

Clicking on "learn More" just gives me a ton of information about "insecure" websites, etc.

I think jscher 2000 has the answer. Amazon changed away from the www and neglected to redirect people to the new address. In any case, I have changed my bookmark and can now, once again, easily access the smile.amazon website. Thank all for your interest and help.