X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Unable to view SVG image, any help?

Kuphostiwe

Hi,

I have an old vehicle service manual that uses html, js, xml, and SVG objects populated by js and xml forms. The links on the webpages work, but the images fail to display.

Attached is an example of an SVG file that fails to display in a web browser (Edge, IE, Firefox, Chrome, IETab in Chome (all latest versions as of April 2018). Other SVG files like https://commons.wikimedia.org/wiki/File:Test.svg work correctly.

I can open the attached .svg file with Inkscape and view the image, but doing this is very cumbersome.

Any ideas on how to get these to display in Firefox? Thanks!

Hi, I have an old vehicle service manual that uses html, js, xml, and SVG objects populated by js and xml forms. The links on the webpages work, but the images fail to display. Attached is an example of an SVG file that fails to display in a web browser (Edge, IE, Firefox, Chrome, IETab in Chome (all latest versions as of April 2018). Other SVG files like https://commons.wikimedia.org/wiki/File:Test.svg work correctly. I can open the attached .svg file with Inkscape and view the image, but doing this is very cumbersome. Any ideas on how to get these to display in Firefox? Thanks!

Isisombululo esikhethiwe

The file works if I add the SVG namespace.

<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="100%" height="100%" viewBox="0 0 250 400">
Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17670 izisombululo 159841 izimpendulo
Kuphostiwe

You can't attach a SVG file and otherwise it might be converted. You would have to print the SVG code in a reply or post a link.

You can check the Web Console for error messages about SVG.

You can't attach a SVG file and otherwise it might be converted. You would have to print the SVG code in a reply or post a link. You can check the Web Console for error messages about SVG. *https://developer.mozilla.org/en/Tools/Web_Console

Umnikazi wombuzo

Of course it wouldn't attach! I'll get a link shortly...

Of course it wouldn't attach! I'll get a link shortly...

Umnikazi wombuzo

Here a link to an example svg file that I am having trouble with

https://www.dropbox.com/s/x0i33bbyph2latf/2174253.svg?dl=0

I'll checkout the Web Console.

Here a link to an example svg file that I am having trouble with https://www.dropbox.com/s/x0i33bbyph2latf/2174253.svg?dl=0 I'll checkout the Web Console.

Umnikazi wombuzo

Hmmm, when opening in Firefox I get "This XML file does not appear to have any style information associated with it. The document tree is shown below." and the contents of the file (the xml data). The console is blank when viewing just the svg file.

In other browsers I get various bits of info that are parts of data in the xml, but not the image I am expecting (wire harness connector).

Perhaps this SVG file is not a standard format?

Hmmm, when opening in Firefox I get "This XML file does not appear to have any style information associated with it. The document tree is shown below." and the contents of the file (the xml data). The console is blank when viewing just the svg file. In other browsers I get various bits of info that are parts of data in the xml, but not the image I am expecting (wire harness connector). Perhaps this SVG file is not a standard format?
cor-el
  • Top 10 Contributor
  • Moderator
17670 izisombululo 159841 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

The file works if I add the SVG namespace.

<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="100%" height="100%" viewBox="0 0 250 400">
The file works if I add the SVG namespace. <pre><nowiki> <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="100%" height="100%" viewBox="0 0 250 400"></nowiki></pre>

Umnikazi wombuzo

Excellent! This is a huge step in the right direction! I can mass edit files easily enough.

Next hurdle...with the namespace you added I can view the file in Firefox, but the text is not rendered as I would expect. Attached is a comparison of Firefox left versus Inkscape right. Any ideas here?

If these are just SVG issues instead of browser issues is there an SVG support forum that you would recommend?

Thanks again!
Excellent! This is a huge step in the right direction! I can mass edit files easily enough. Next hurdle...with the namespace you added I can view the file in Firefox, but the text is not rendered as I would expect. Attached is a comparison of Firefox left versus Inkscape right. Any ideas here? If these are just SVG issues instead of browser issues is there an SVG support forum that you would recommend? Thanks again!
cor-el
  • Top 10 Contributor
  • Moderator
17670 izisombululo 159841 izimpendulo
Kuphostiwe
Try to ask advice at the Stack Overflow forum site. *http://stackoverflow.com/questions/ *https://support.mozilla.org/en-US/kb/where-go-developer-support