Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can I revert the behavior of the search box to disable the search settings popup?

  • 2 uphendule
  • 1 inale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu kurt_genus

more options

The search box to the right of the address bar used to be a regular text field. I could put text in there and initiate a search via engines which were configured separately (usually just once).

For some time the behavior has been changed to bring up a popup window with search options. This is really annoying. It prevents me from being about to dbl click on the search box text to clear it, it prevents me from seeing my old txt, and it serves no purpose that I can see other than to annoy the living crap out of me.

I thought I saw another user complaining of this (https://support.mozilla.org/en-US/questions/1034054), but the suggested fix appears to no longer work as I don't see the option in about:config.

Isisombululo esikhethiwe

Sorry for really long gap in responding. It turns out that this isn't a constant problem. At the time I posted I thought that it was.

I tried your suggestion and it appeared to work. I then tried restarting as I normally would and... still no problem.

So, it appears that this problem with the search behavior only starts after I've had the browser open for some period of time. This is my work computer and I basically never shut it down so this could end up being a long time.

I could post here again, but as long as there's a work around to just restart I'll probably just do that.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

There's no built-in way to modify the general functioning of the search box, which is to drop the panel with suggestions, one-click search icons, page-specific stuff, and the search options button, if there are any characters in the box. Some add-ons may be able to modify it in Firefox 55-56, and custom style rules can hide or rearrange some things.

That said, under no circumstances should a separate dialog pop-up when you click or double-click in the search bar. Nor should the drop-panel block your use of the search box itself.

Do you have any other add-ons or custom style rules which might be modifying the search bar or its drop-panel in a dysfunctional way -- that is, something incompatible with Firefox 55 (or whenever the problem started)? To rule that out, we often suggest:

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

more options

Isisombululo Esikhethiwe

Sorry for really long gap in responding. It turns out that this isn't a constant problem. At the time I posted I thought that it was.

I tried your suggestion and it appeared to work. I then tried restarting as I normally would and... still no problem.

So, it appears that this problem with the search behavior only starts after I've had the browser open for some period of time. This is my work computer and I basically never shut it down so this could end up being a long time.

I could post here again, but as long as there's a work around to just restart I'll probably just do that.