X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

2 firefox.exe running in the background whenever I open Firefox

Kuphostiwe

Whenever I open Firefox, there are two firefox.exe running the background whenever I open the browser. Whenever I try to close the second one, it crashes all of the tabs that are on the browser, and whenever I reload the tabs, it pops up again.

I've scanned my computer multiple times with multiple anti-viruses, but there was no viruses to be found. I've also disabled the plugins that I thought were the issue, and refreshed Firefox, but it was still there. I restarted my computer, no luck in doing that. Uninstalling and reinstalling Firefox didn't even do the trick either.

The double processes sky-rockets my RAM and CPU, and it's starting to get annoying. Please help! I appreciate any cooperation!

Whenever I open Firefox, there are two firefox.exe running the background whenever I open the browser. Whenever I try to close the second one, it crashes all of the tabs that are on the browser, and whenever I reload the tabs, it pops up again. I've scanned my computer multiple times with multiple anti-viruses, but there was no viruses to be found. I've also disabled the plugins that I thought were the issue, and refreshed Firefox, but it was still there. I restarted my computer, no luck in doing that. Uninstalling and reinstalling Firefox didn't even do the trick either. The double processes sky-rockets my RAM and CPU, and it's starting to get annoying. Please help! I appreciate any cooperation!

Okulungisiwe ngu TheCameraEye97

Isisombululo esikhethiwe

This could indicate that your Firefox is using a new "multiprocess" feature.

e10s

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems: many users find it faster, some find it slower, for many it's neutral. There probably is somewhat more memory use than when everything runs in a single firefox.exe process.

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

If you think Firefox is not performing well or is using an unreasonable amount of resources now, you could evaluate whether e10s is causing this problem by turning it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

Funda le mpendulo ngokuhambisana nalesi sihloko 95

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • Firefox 50.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.0; rv:50.0) Gecko/20100101 Firefox/50.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/50.0/WINNT/en-US/

Izandiso

  • Adblock Plus 2.8.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • YouTube Video and Audio Downloader 0.5.5 (feca4b87-3be4-43da-a1b1-137c24220968@jetpack)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: ATI Radeon Xpress Series
  • adapterDescription2:
  • adapterDeviceID: 0x5975
  • adapterDeviceID2:
  • adapterDrivers: atiumdag atiumdva atitmmxx
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 010f1025
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'8.56.1.15']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.23845
  • driverDate: 6-2-2008
  • driverDate2:
  • driverVersion: 8.501.0.0
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'blacklisted', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_FEATURE_FAILURE_AMD1', u'type': u'env'}]}, {u'status': u'blacklisted', u'description': u'Direct3D9 Compositing', u'name': u'D3D9_COMPOSITING', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_FEATURE_FAILURE_AMD1', u'type': u'env'}]}, {u'status': u'unavailable', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}]}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}]}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'ApzWheelInput': 1, u'AzureContentBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'8.56.1.15']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webgl2Renderer: (no info)
  • webglRenderer: Google Inc. -- ANGLE (Software Adapter Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

This could indicate that your Firefox is using a new "multiprocess" feature.

e10s

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems: many users find it faster, some find it slower, for many it's neutral. There probably is somewhat more memory use than when everything runs in a single firefox.exe process.

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

If you think Firefox is not performing well or is using an unreasonable amount of resources now, you could evaluate whether e10s is causing this problem by turning it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

This could indicate that your Firefox is using a new "multiprocess" feature. '''e10s''' One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems: many users find it faster, some find it slower, for many it's neutral. There probably is somewhat more memory use than when everything runs in a single firefox.exe process. ''Are you using e10s?'' You can check whether you have this feature turned on as follows. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s. ''If you are using e10s:'' If you think Firefox is not performing well or is using an unreasonable amount of resources now, you could evaluate whether e10s is causing this problem by turning it off as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autos''' and pause while the list is filtered (3) Double-click the '''browser.tabs.remote.autostart.2''' preference to switch the value from true to false ''Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart'' At your next Firefox startup, it should run in the traditional way. Any difference?

Impendulo Ewusizo

Thank you so much jscher2000! It helped me a lot!

Thank you so much jscher2000! It helped me a lot!
motox22a 1 izisombululo 4 izimpendulo
Kuphostiwe

I found that this was also a problem for me on my Windows 10 32-bit computers. With E10s enabled I could not launch ANY EMAIL URLs from ANY EMAIL PROGRAM. They would open Firefox when I clicked on a Email URL but Firefox would hang after that and not go anywhere. When I toggled browser.tabs.remote.autostart.2 preference to switch the value from true to false and then restarted Firefox (51.0.1) the problem was resolved and I could again launch EMAIL URLs from my Email Clients even when Firefox was closed. With E10s enabled it could only launch the URLs correctly with Firefox already open...If Firefox was closed and I clicked on an EmaiL Url from my Email Clients Firefox would open and then hang. DISABLING E10s solved the issue. (Win10 32-bit).

I found that this was also a problem for me on my Windows 10 32-bit computers. With E10s enabled I could not launch ANY EMAIL URLs from ANY EMAIL PROGRAM. They would open Firefox when I clicked on a Email URL but Firefox would hang after that and not go anywhere. When I toggled browser.tabs.remote.autostart.2 preference to switch the value from true to false and then restarted Firefox (51.0.1) the problem was resolved and I could again launch EMAIL URLs from my Email Clients even when Firefox was closed. With E10s enabled it could only launch the URLs correctly with Firefox already open...If Firefox was closed and I clicked on an EmaiL Url from my Email Clients Firefox would open and then hang. DISABLING E10s solved the issue. (Win10 32-bit).