X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why can't I save a web page as a text file?

Kuphostiwe

Until yesterday I was able to save a web page as a text file. Now, it will only save a web page as an html file even though the Format selected is text file. I am currently using Firefox 50.0.

Until yesterday I was able to save a web page as a text file. Now, it will only save a web page as an html file even though the Format selected is text file. I am currently using Firefox 50.0.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.16
  • Simple plug-in that handles Citrix connection files
  • Coupons Inc., Coupon Printing FireFox Plugin
  • Provides information about the default web browser
  • Garmin Communicator Plug-in Version 4.1.0.0
  • Garmin Communicator Plug-in Version 4.2.0.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 22.0 r0
  • 5.1.41212.0
  • WebEx64 General Plugin Container Version 202
  • iPhoto6

Isisebenziso

  • Firefox 50.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:50.0) Gecko/20100101 Firefox/50.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/50.0/Darwin/en-US/

Izandiso

  • AmazonSmile 1Button for Firefox 1.0.1-signed.1-signed (smile1Button@amazon.com)
  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Garmin Communicator 4.1.0.1-signed.1-signed ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Akusebenzi)
  • LeechBlock 1.0.5 ({a95d8332-e4b4-6e7f-98ac-20b733364387}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription:
  • adapterDeviceID: 0x6740
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • crashGuards: []
  • currentAudioBackend: audiounit
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'TileHeight': 512, u'TileWidth': 512, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 1, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webgl2Renderer: (no info)
  • webglRenderer: ATI Technologies Inc. -- AMD Radeon HD 6770M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
baltohome 0 izisombululo 7 izimpendulo
Kuphostiwe

Same problem with FF 50.0. I set format as "text files" but only get a html file. Url of article: http://www.nytimes.com/2016/11/17/technology/personaltech/encryption-privacy.html?src=me When I save as a text file, this is the result: Protecting Your Digital Life.html. Viewing the page info: type is text/html.

Same problem with FF 50.0. I set format as "text files" but only get a html file. Url of article: http://www.nytimes.com/2016/11/17/technology/personaltech/encryption-privacy.html?src=me When I save as a text file, this is the result: Protecting Your Digital Life.html. Viewing the page info: type is text/html.
jscher2000
  • Top 10 Contributor
8693 izisombululo 71056 izimpendulo
Kuphostiwe

If you switch the format selector to Web Page (either one) then back to Text, the file extension changes to .txt.

I don't know why that's happening, seems like a bug that the file extension isn't getting correctly assigned.

The content is the same either way -- text plus link addresses in < angle brackets >. It's not the true HTML code of the page, but it's also not limited to the visible text.

If you need to rename an already saved file from a .htm extension to a .txt extension, Windows makes that a little more difficult by hiding those extensions. You can switch that to showing all file extensions. See: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

If it's a problem on MacOS, perhaps there is a similar setting.

If you switch the format selector to Web Page (either one) then back to Text, the file extension changes to .txt. I don't know why that's happening, seems like a bug that the file extension isn't getting correctly assigned. The content is the same either way -- text plus link addresses in < angle brackets >. It's not the true HTML code of the page, but it's also not limited to the visible text. If you need to rename an already saved file from a .htm extension to a .txt extension, Windows makes that a little more difficult by hiding those extensions. You can switch that to showing all file extensions. See: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions If it's a problem on MacOS, perhaps there is a similar setting.

Umnikazi wombuzo

Thanks for the suggestion. However, switching o the format selector to Web Page (either one) then back to Text, does not change the file extension to .txt. It appears as if the text format is just not recognized.

By the way, I am working on a Mac.

Thanks for the suggestion. However, switching o the format selector to Web Page (either one) then back to Text, does not change the file extension to .txt. It appears as if the text format is just not recognized. By the way, I am working on a Mac.
jscher2000
  • Top 10 Contributor
8693 izisombululo 71056 izimpendulo
Kuphostiwe

Hi kokokiva, I don't have a Mac, so I can only offer a guess. What if you manually edit .htm to .txt before saving?

Hi kokokiva, I don't have a Mac, so I can only offer a guess. What if you manually edit .htm to .txt before saving?

Umnikazi wombuzo

I tried that but when the document saved it was still a .html file, my change was ignored. For now I am saving the page as an .html file and then opening the document in a text editor and saving the document as a ,txt file. This removes the images but preserves the formatting. Okay for one document, multiple documents are a pain.

I tried that but when the document saved it was still a .html file, my change was ignored. For now I am saving the page as an .html file and then opening the document in a text editor and saving the document as a ,txt file. This removes the images but preserves the formatting. Okay for one document, multiple documents are a pain.

Okulungisiwe ngu kokokiva

jscher2000
  • Top 10 Contributor
8693 izisombululo 71056 izimpendulo
Kuphostiwe

Unfortunately, I don't know what changed or how to work with it.

As a workaround, what do you think about using a bookmarklet? That's a line of script which you save on your Bookmarks Toolbar or Bookmarks Menu so it's handy when you want to run it. I created a script to grab whatever text you have selected in a page and display it in a new tab where you can save it as a plain text file. (To select the entire page, use Command+a or on Windows Ctrl+a.)

Unfortunately, I wasn't able to figure out how to pre-fill a useful file name, so you'll have to type a name. I inserted the document title on the first line above the selection in case that helps.

You can install the bookmarklet from this page:

https://www.jeffersonscher.com/res/sumomarklets.html#PopSelection

If you try it, let me know what you think.

Unfortunately, I don't know what changed or how to work with it. As a workaround, what do you think about using a bookmarklet? That's a line of script which you save on your Bookmarks Toolbar or Bookmarks Menu so it's handy when you want to run it. I created a script to grab whatever text you have selected in a page and display it in a new tab where you can save it as a plain text file. (To select the entire page, use Command+a or on Windows Ctrl+a.) Unfortunately, I wasn't able to figure out how to pre-fill a useful file name, so you'll have to type a name. I inserted the document title on the first line above the selection in case that helps. You can install the bookmarklet from this page: https://www.jeffersonscher.com/res/sumomarklets.html#PopSelection If you try it, let me know what you think.
baltohome 0 izisombululo 7 izimpendulo
Kuphostiwe

I have a Mac and I am not able to insert ".txt" at the end of the file name before saving. See the message below when I tried to do that manuever:

You cannot save this document with extension “.txt” at the end of the name. The required extension is “.html”. You can choose to use both, so that the file name ends in ".txt.html".

Whereas before FF50 ".html" shown in the "save as" file window, which I could erase and then save as a text file, there is no extension visible. The default extension seems now to be "html".

I have a Mac and I am not able to insert ".txt" at the end of the file name before saving. See the message below when I tried to do that manuever: You cannot save this document with extension “.txt” at the end of the name. The required extension is “.html”. You can choose to use both, so that the file name ends in ".txt.html". Whereas before FF50 ".html" shown in the "save as" file window, which I could erase and then save as a text file, there is no extension visible. The default extension seems now to be "html".

Umnikazi wombuzo

You described my problem perfectly!

You described my problem perfectly!
jscher2000
  • Top 10 Contributor
8693 izisombululo 71056 izimpendulo
Kuphostiwe

I poked around in the bug tracking system and the source code for the past hour and can't find any significant changes to how the "file picker" works that would cause it to return HTML to Firefox as your selection even when you selected Text.

As two possibly relevant data points:

Ruling Out Extensions

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/Alt key when starting Firefox. (On Windows, hold down the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

e10s = Multiprocess Firefox

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process. More and more users are enrolled with each release, so you might not have started using it until Firefox 50. To discover add-on incompatibilities and internal cross-process glitches, the developers need feedback on any new problems that occur only with e10s enabled. (Link to file a new bug: https://bugzilla.mozilla.org/enter_bug.cgi)

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero (e.g., 1/1). If so, you are using e10s.

If you are using e10s:

You could evaluate whether e10s is causing this problem by turning it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

I poked around in the bug tracking system and the source code for the past hour and can't find any significant changes to how the "file picker" works that would cause it to return HTML to Firefox as your selection even when you selected Text. As two possibly relevant data points: '''Ruling Out Extensions''' Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the option/Alt key when starting Firefox. (On Windows, hold down the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? '''e10s = Multiprocess Firefox''' One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process. More and more users are enrolled with each release, so you might not have started using it until Firefox 50. To discover add-on incompatibilities and internal cross-process glitches, the developers need feedback on any new problems that occur only with e10s enabled. (Link to file a new bug: [https://bugzilla.mozilla.org/enter_bug.cgi]) ''Are you using e10s?'' You can check whether you have this feature turned on as follows. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter/Return In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero (e.g., 1/1). If so, you are using e10s. ''If you are using e10s:'' You could evaluate whether e10s is causing this problem by turning it off as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autos''' and pause while the list is filtered (3) Double-click the '''browser.tabs.remote.autostart.2''' preference to switch the value from true to false ''Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart'' At your next Firefox startup, it should run in the traditional way. Any difference?
baltohome 0 izisombululo 7 izimpendulo
Kuphostiwe

jscher2000:

I tried the first solution, restarting in safe mode with add-ons disabled. However, I get the same result: the default file saved is ".html".

I see that I am apparently using e10s: my numbers are 1/1. So I will now try the second solution. Will get back with results.

Thanks for the help.

jscher2000: I tried the first solution, restarting in safe mode with add-ons disabled. However, I get the same result: the default file saved is ".html". I see that I am apparently using e10s: my numbers are 1/1. So I will now try the second solution. Will get back with results. Thanks for the help.
baltohome 0 izisombululo 7 izimpendulo
Kuphostiwe

Okay, I tried the second solution: Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false.

Unfortunately I get the same result: ".html" is the default file saved.

Using MacBook Pro: OS X 10.9.5

Okay, I tried the second solution: Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false. Unfortunately I get the same result: ".html" is the default file saved. Using MacBook Pro: OS X 10.9.5

Umnikazi wombuzo

Thanks for trying. I really appreciate it. As a temporary measure I have reverted back to Firefox 49.0.2 using Time Machine.

Thanks for trying. I really appreciate it. As a temporary measure I have reverted back to Firefox 49.0.2 using Time Machine.
jscher2000
  • Top 10 Contributor
8693 izisombululo 71056 izimpendulo
Kuphostiwe

Thanks for testing. It sounds like time to file a bug report.

https://bugzilla.mozilla.org/enter_bug.cgi

Thanks for testing. It sounds like time to file a bug report. https://bugzilla.mozilla.org/enter_bug.cgi
baltohome 0 izisombululo 7 izimpendulo
Kuphostiwe

I have filed a bug report: Bug 1320377.

Let's hope for a solution.

Thanks all.

I have filed a bug report: Bug 1320377. Let's hope for a solution. Thanks all.

Umnikazi wombuzo

Thank you!

Thank you!
jscher2000
  • Top 10 Contributor
8693 izisombululo 71056 izimpendulo
Kuphostiwe

Thank you for filing the bug report.

The developers are actively working on it, and most likely you will be able to override the .html with a .txt extension manually (not sure if it will be possible to make it the default).

Code changes may take anywhere from six to eighteen weeks to actually come through. Since this change seems simple as I've described it, I don't think it will be on the shorter end, give or take a week or two for the holidays...

If you want to read the comments so far, the bug can be found on the following link: https://bugzilla.mozilla.org/show_bug.cgi?id=1320377. To anyone new to the bug, please refrain from adding "me too" or "hurry up" comments -- that doesn't help anyone. Bugzilla Etiquette

Thank you for filing the bug report. The developers are actively working on it, and most likely you will be able to override the .html with a .txt extension manually (not sure if it will be possible to make it the default). Code changes may take anywhere from six to eighteen weeks to actually come through. Since this change seems simple as I've described it, I don't think it will be on the shorter end, give or take a week or two for the holidays... If you want to read the comments so far, the bug can be found on the following link: [https://bugzilla.mozilla.org/show_bug.cgi?id=1320377]. To anyone new to the bug, please refrain from adding "me too" or "hurry up" comments -- that doesn't help anyone. [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette]
baltohome 0 izisombululo 7 izimpendulo
Kuphostiwe

Jscher2000,

I followed the discussion on Bugzilla and this issue seems to be resolved? However, one tester used Mac OS X 10.11.5 and Mac OS 10.12.1, which is above my current system.

There is an update for FF 50 being offered; am I too anxious to expect to be able to save files in ".txt"?

Jscher2000, I followed the discussion on Bugzilla and this issue seems to be resolved? However, one tester used Mac OS X 10.11.5 and Mac OS 10.12.1, which is above my current system. There is an update for FF 50 being offered; am I too anxious to expect to be able to save files in ".txt"?
jscher2000
  • Top 10 Contributor
8693 izisombululo 71056 izimpendulo
Kuphostiwe

Hi baltohome, it's unlikely that Firefox 50 will get that change, but I just added a comment asking about getting it into Firefox 51-52, since it looks unusually simple as changes go.

Hi baltohome, it's unlikely that Firefox 50 will get that change, but I just added a comment asking about getting it into Firefox 51-52, since it looks unusually simple as changes go.

Okulungisiwe ngu jscher2000

baltohome 0 izisombululo 7 izimpendulo
Kuphostiwe

Thanks for following up. I saw that in one response FF Nightly 53.0a1 was mentioned, so my hope for FF 50 was too optimistic. I guess that my expectations are a bit too high. Will be more patient.

Thanks for following up. I saw that in one response FF Nightly 53.0a1 was mentioned, so my hope for FF 50 was too optimistic. I guess that my expectations are a bit too high. Will be more patient.