Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

OS X Firefox lockPref configuration error

  • 2 uphendule
  • 2 zinale nkinga
  • 8 views
  • Igcine ukuphendulwa ngu ladyquas

more options

I am having issues getting lockPref working on my Mac. I have followed instructions here, as well as looking in other places for solutions. I have created a mozilla.cfg file, as well as a local-settings.js file in /Applications/Firefox/Contents/Resources/defaults/pref, as follows:

mozilla.cfg

   //
   lockPref("extensions.shownSelectionUI", true);
   lockPref("extensions.autoDisableScopes", 11);

local-settings.js

   pref("general.config.obscure_value", 0);
   pref("general.config.filename", "mozilla.cfg");

These are both saved using Windows Latin encoding (have tried Windows Roman too). When opening Firefox, I am getting an error dialogue saying, "Failed to read the configuration file. Please contact your system administrator". I'm not sure where to go from here, as other solutions have involved UTF encoding problems and incorrect configuration values - I saved an empty mozilla.cfg file to attempt to rule that out, and the problem still persists. I have even substituted with files downloaded from GitHub, as they should have the correct encoding - no juice.

FYI I'm using OS X 10.11.5 and Firefox 42.0. Thanks.

I am having issues getting lockPref working on my Mac. I have followed instructions here, as well as looking in other places for solutions. I have created a mozilla.cfg file, as well as a local-settings.js file in /Applications/Firefox/Contents/Resources/defaults/pref, as follows: mozilla.cfg // lockPref("extensions.shownSelectionUI", true); lockPref("extensions.autoDisableScopes", 11); local-settings.js pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg"); These are both saved using Windows Latin encoding (have tried Windows Roman too). When opening Firefox, I am getting an error dialogue saying, "Failed to read the configuration file. Please contact your system administrator". I'm not sure where to go from here, as other solutions have involved UTF encoding problems and incorrect configuration values - I saved an empty mozilla.cfg file to attempt to rule that out, and the problem still persists. I have even substituted with files downloaded from GitHub, as they should have the correct encoding - no juice. FYI I'm using OS X 10.11.5 and Firefox 42.0. Thanks.

Isisombululo esikhethiwe

hi ladyquas, please note that the mozilla.cfg should not be placed in the same folder as local-settings.js but directly in the firefox installation folder (where the firefox executable stays as well).

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (2)

more options

Isisombululo Esikhethiwe

hi ladyquas, please note that the mozilla.cfg should not be placed in the same folder as local-settings.js but directly in the firefox installation folder (where the firefox executable stays as well).

more options

philipp, thank you for clarifying - it didn't even occur to me that the mozilla.cfg file would be in a different location.

My files are now as follows: /Applications/Firefox.app/Contents/Resources/mozilla.cfg /Applications/Firefox.app/Contents/Resources/defaults/pref/local-settings.js

And works like a dream.