Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

open new tab but does not automatically display it

  • 5 uphendule
  • 2 zinale nkinga
  • 130 views
  • Igcine ukuphendulwa ngu ginnpr

more options

On a web page, open a link in a new tab. Tab opens, but still displays original tab. Want firefox to automatically go to new tab.

All Replies (5)

more options

Type about:preferences#general<enter> in the address bar. Under Tabs, turn on When I open a link in a new tab, switch to it immediately

more options

Note that you can additionally hold down the Shift key to toggle loading a link in the background if you left-click pr middle-click a link.

more options

when I open a new tab - it automatically loads my homepage, cannot figure out how to just have the blank tab. Thanks

more options

Hi ginnpr

The current Firefox release would by default open the about:newtab page if you open a new tab.

The browser.newtab.url pref is no longer supported in Firefox (41+), so it is no longer possible to set the new tab page via this pref.

You can look at this extension to set the new tab page:

You can set the new tab URL via the Options/Preferences of the extension on the about:addons page.

You can look at this extension if you use the home page as the new tab page.

Classic Theme Restorer includes this feature as well. You find "New tab page url" in the Tabs (2) section.

You can use pages like these:

  • the default new tab page with the tiles is about:newtab
  • the default home page is about:home
  • for a blank page use about:blank
  • for Super Start use about:superstart
  • use the URL of a web page

See the about:about page for available about pages.

more options

Thanks so much - did the 1st suggestion - tab override - it is strange this problem just started yesterday. Thanks again.