X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

problems viewing and downloading pdf files from email attachment

Kuphostiwe

When I try to view a pdf file that is attached to an email it opens a poor copy with word online, that can't be printed.

When I try and download the pdf file from the email attachment a dialog box ALWAYS pops up asking "what to do with this file?" The dialog already has my default reader selected and the "do this automatically for files like this from now on" box is checked.

Every time I try and download the dialog comes up.

I'm running windows 10, firefox 45.0.1, foxit reader 7.1.5.425. Emails are on outlook.

When I try to view a pdf file that is attached to an email it opens a poor copy with word online, that can't be printed. When I try and download the pdf file from the email attachment a dialog box ALWAYS pops up asking "what to do with this file?" The dialog already has my default reader selected and the "do this automatically for files like this from now on" box is checked. Every time I try and download the dialog comes up. I'm running windows 10, firefox 45.0.1, foxit reader 7.1.5.425. Emails are on outlook.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • 20-20 3D Viewer for IKEA - Mozilla Plug-In v5.0.94.1
  • Citrix Online App Detector Plugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • GEPlugin
  • Google Update
  • Logitech Harmony Remote Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • LastPass Plugin
  • Nokia Suite Enabler Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • Unity Player 4.5.5f1
  • iTunes Detector Plug-in

Isisebenziso

  • Firefox 45.0.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/45.0.1/WINNT/en-US/

Izandiso

  • 20-20 3D Viewer - IKEA 5.0.94.1 (2020Player_IKEA@2020Technologies.com)
  • Adblock Plus 2.7.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Firefox Hello Beta 1.1.14 (loop@mozilla.org)
  • LastPass 3.3.1 (support@lastpass.com)
  • Freemake Video Converter Plugin 1.0.0 (fmconverter@gmail.com) (Akusebenzi)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: AMD Radeon HD 5450
  • adapterDescription2:
  • adapterDeviceID: 0x68f9
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 21271462
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 11-4-2015
  • driverDate2:
  • driverVersion: 15.201.1151.1008
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 5450 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
Wesley Branton
  • Top 10 Contributor
649 izisombululo 5257 izimpendulo
Kuphostiwe

In order to change the default reader for PDF files (to not open PDF files with Firefox's internal PDF reader), follow these steps:

  1. Click the menu button New Fx Menu and click Options (Preferences for Linux and Mac).
  2. In the Options (Preferences for Linux and Mac) tab (window for previous than 38.0 firefox version), select the Applications panel.
  3. In the Search field, type PDF. You should find Portable Document Format (PDF).
  4. On the right hand side you should find an Action column. Use that to select your favorite PDF reader. In order to view PDF files in Firefox, choose Preview in Firefox.

Did this fix your problems? Please report back to us!

In order to change the default reader for PDF files (to not open PDF files with Firefox's internal PDF reader), follow these steps: #Click the menu button [[Image:New Fx Menu]] and click Options (Preferences for Linux and Mac). #In the Options (Preferences for Linux and Mac) tab (window for previous than 38.0 firefox version), select the ''Applications'' panel. #In the ''Search'' field, type ''PDF''. You should find ''Portable Document Format (PDF)''. #On the right hand side you should find an ''Action'' column. Use that to select your favorite PDF reader. In order to view PDF files in Firefox, choose ''Preview in Firefox''. Did this fix your problems? Please report back to us!

Umnikazi wombuzo

Thank you. I have already checked that and foxit reader is selected. Also there is no choice to view pdf files in firefox, which I find strange.

Thank you. I have already checked that and foxit reader is selected. Also there is no choice to view pdf files in firefox, which I find strange.
Wesley Branton
  • Top 10 Contributor
649 izisombululo 5257 izimpendulo
Kuphostiwe

You could have to set your default PDF reader on your operating system. To do so, please refer to this How-To Geek article:

You could have to set your default PDF reader on your operating system. To do so, please refer to this ''How-To Geek'' article: *[http://www.howtogeek.com/237512/how-to-change-the-default-pdf-reader-in-windows-10/ How to Change the Default PDF Reader in Windows 10]

Umnikazi wombuzo

Wesley, I really appreciate your suggestions. The defualt reader is set to foxit. I'm really puzzled why I'm not given the choice to view in firefox pdf viewer or why the dialog always comes up when I download.

mark

Wesley, I really appreciate your suggestions. The defualt reader is set to foxit. I'm really puzzled why I'm not given the choice to view in firefox pdf viewer or why the dialog always comes up when I download. mark
Wesley Branton
  • Top 10 Contributor
649 izisombululo 5257 izimpendulo
Kuphostiwe

It was suggested by some other support team members that you try renaming the mimeTypes.rdf file in your Firefox profile to mimeTypes.rdf.old and then reconfigure your default PDF reader in Firefox.

For more information on locating your Firefox profile, please refer to this Mozilla support article:

Warning: Close Firefox completely before completing the steps above.

Note: If this doesn't fix the issue, delete the new mimeTypes.rdf file and rename the mimeTypes.rdf.old file back to mimeTypes.rdf.

It was suggested by some other support team members that you try renaming the <code>mimeTypes.rdf</code> file in your Firefox profile to <code>mimeTypes.rdf.old</code> and then reconfigure your default PDF reader in Firefox. For more information on locating your Firefox profile, please refer to this Mozilla support article: *[[Profiles - Where Firefox stores your bookmarks, passwords and other user data]] '''Warning:''' Close Firefox completely before completing the steps above. '''Note:''' If this doesn't fix the issue, delete the new <code>mimeTypes.rdf</code> file and rename the <code>mimeTypes.rdf.old</code> file back to <code>mimeTypes.rdf</code>.

Umnikazi wombuzo

Thanks, I had tried that too. But no luck. I will try again right now, just to confirm.

Thanks, I had tried that too. But no luck. I will try again right now, just to confirm.

Umnikazi wombuzo

No It didn't make any difference. I was thinking about "preview in firefox" and I do have that as an option. But in Outlook "view online" takes me to some funky word viewer that doesn't work well... perhaps that is an outlook problem? With the "download" choice it seems like firefox is stuck on always ask. I tried switching reader do adobe, but again it always asks for reader instead of doing it automatically.

No It didn't make any difference. I was thinking about "preview in firefox" and I do have that as an option. But in Outlook "view online" takes me to some funky word viewer that doesn't work well... perhaps that is an outlook problem? With the "download" choice it seems like firefox is stuck on always ask. I tried switching reader do adobe, but again it always asks for reader instead of doing it automatically.

Umnikazi wombuzo

I tried one more thing (mentioned elsewhere), I turned off all extensions (2) and plugins(7) (I don't have any services).

Made no difference.

I tried one more thing (mentioned elsewhere), I turned off all extensions (2) and plugins(7) (I don't have any services). Made no difference.
Wesley Branton
  • Top 10 Contributor
649 izisombululo 5257 izimpendulo
Kuphostiwe

On Outlook, selecting their view option will open it in their OneDrive platform. I think that Outlook may simply have some code that prevents Firefox from setting the default PDF viewer.

Please consider contacting the Microsoft support team regarding this issue. You can also try filing a bug report so that the Mozilla developers can take a look at the issue and potentially create a patch.

Sorry for any inconvenience.

On Outlook, selecting their view option will open it in their OneDrive platform. I think that Outlook may simply have some code that prevents Firefox from setting the default PDF viewer. Please consider contacting the Microsoft support team regarding this issue. You can also try [https://bugzilla.mozilla.org/ filing a bug report] so that the Mozilla developers can take a look at the issue and potentially create a patch. Sorry for any inconvenience.

Umnikazi wombuzo

Wesley, I agree outlook might be the problem with the view option. On the download option I have the same issue whether I'm using my hotmail account (outlook) or my gmail account. When trying to download, even though "always do this in the future" is checked it asks me everytime. Do you get that dialog when trying to open a pdf attachment in a email? mark

Wesley, I agree outlook might be the problem with the view option. On the download option I have the same issue whether I'm using my hotmail account (outlook) or my gmail account. When trying to download, even though "always do this in the future" is checked it asks me everytime. Do you get that dialog when trying to open a pdf attachment in a email? mark
Wesley Branton
  • Top 10 Contributor
649 izisombululo 5257 izimpendulo
Kuphostiwe

I just tested the issue in my Firefox browser and the issue does occur for me as well. Therefore, if you file a bug report about the issue (using the link provided above), our developers can take a look at the issue and search for a potential patch in the future versions of Firefox.

I just tested the issue in my Firefox browser and the issue does occur for me as well. Therefore, if you file a bug report about the issue (using the link provided above), our developers can take a look at the issue and search for a potential patch in the future versions of Firefox.

Umnikazi wombuzo

thanks,

at least I know I'm not crazy...... well not totally
thanks, at least I know I'm not crazy...... well not totally
Wesley Branton
  • Top 10 Contributor
649 izisombululo 5257 izimpendulo
Kuphostiwe

No problem. Sorry I couldn't help you fix the issue, but hopefully the developers can fix this issue in a newer version of Firefox.

No problem. Sorry I couldn't help you fix the issue, but hopefully the developers can fix this issue in a newer version of Firefox.