Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When I compile a program in Visual Basic 8, Firefox runs, the program does not compile.

  • 10 uphendule
  • 2 zinale nkinga
  • 423 views
  • Igcine ukuphendulwa ngu FredMcD

more options

This worked last year. I have VB8, VB 2015. VB 2015 works. I can compile programs and it works properly. All of a sudden, I can't compile with VB 8. I end up in Firefox. I even made Internet Explorer the default browser, just in case MS did something sneaky. But Firefox jumps up there with no website visible. I don't want to uninstall Firefox. Can somebody point in the correct direction?

Larry

Isisombululo esikhethiwe

Actually, I don't. It is a Firefox problem and only occurs when I make him the default browser. Right now I have Internet Explorer as my default and Firefox is the one I run. Everything is working fine this way. But when I set Firefox as my default browser I can't compile with Visual Studio/Visual Basic 8. No big deal, I'll just run it this way. I've tried it twice and get the same results. But thanks anyway.

LarryRichards1

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (10)

more options

What are the extensions of the files you are working with?

more options

Not a Firefox end-user support question.

Where to go for developer support: https://support.mozilla.org/en-US/kb/where-go-developer-support

more options

Its Visual Basic, I'm working with a .sln file, but .html and other hyper link extensions are involve. These are personal programs I'm compiling, not for Firefox. I'll bet the problem is with Microsoft. :-)

Larry

more options

I'm not developing for Firefox, but just some Condo software. It has nothing to do with Firefox other than all of a sudden it is launching when I compile something. Only in version 8 of Visual Solutions. Version 2015 is OK. I suspect it really has to do with Microsoft, but I have no way to prove it to me.

Thanks,

Larry

more options

I think the problem is using the same file extension for two different programs. The computer thinks you want to run the html file, and the "Start With" setting is to Firefox. One way is to turn off that "Start With" option on html.

more options

Because of your answer, I uninstalled Firefox and re-installed it. Now everything is honky-dory! Thanks for the push. I couldn't find the 'Start with' place. I thought this should work, unless it was Microsoft causing the problem. For a change, they weren't.

Thanks FredMcD.

LarryRichards1

more options

Woops, spoke too soon. Once I made Firefox the default browser it is doing it again. I guess I'll have to make Internet Explorer the default. :-(

Thanks anyway.

Larry

more options

You will have the same issue.

Control Panel > All Control Panel Items > Default Programs

Set Associations

more options

Isisombululo Esikhethiwe

Actually, I don't. It is a Firefox problem and only occurs when I make him the default browser. Right now I have Internet Explorer as my default and Firefox is the one I run. Everything is working fine this way. But when I set Firefox as my default browser I can't compile with Visual Studio/Visual Basic 8. No big deal, I'll just run it this way. I've tried it twice and get the same results. But thanks anyway.

LarryRichards1

more options

That was very good work. Well Done.