X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I undo a security exception?

Kuphostiwe

I brought up a site that I had been using, but got a security warning, asking if I wanted to make an exception. Because I have been using this site for advertising and was familiar with it, I made an exception, only to find out it kept giving me warnings for other pages on the site. This disturbed me and I would like to undo the security exceptions I have made, but don't know how to access this feature.

I brought up a site that I had been using, but got a security warning, asking if I wanted to make an exception. Because I have been using this site for advertising and was familiar with it, I made an exception, only to find out it kept giving me warnings for other pages on the site. This disturbed me and I would like to undo the security exceptions I have made, but don't know how to access this feature.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Google Update
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; rv:41.0) Gecko/20100101 Firefox/41.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Do you mean you got an error similar to "Untrusted Connection", you expanded the part of the page that says "I understand the risks" and used the "Add Exception" button there?

In that case, you can remove the exception using the Certificate Manager. Here's how:

Open the Options page using:

"3-bar" menu button (or Tools menu) > Options

In the left column click Advanced, then click the "Certificate" mini-tab on that panel, then click the "View Certificates" button.

Individual site exceptions are on the "Servers" tab in the Certificate Manager. Ignore the ones with * for the address and find the sites you recall visiting.

Before deleting it, please look at the Issuer." This will help in tracking down the explanation for needing to add exceptions.

Perhaps it will be obvious from the Certificate Manager listing but, if not, click the certificate you added, then click the View button to call up the certificate viewer. I have attached an example of where to look for issuer information. Often this will point to a problem with Firefox not being fully set up to work with your security software, but there are other possible explanations as well.

Do you mean you got an error similar to "Untrusted Connection", you expanded the part of the page that says "I understand the risks" and used the "Add Exception" button there? In that case, you can remove the exception using the Certificate Manager. Here's how: Open the Options page using: "3-bar" menu button (or Tools menu) > Options In the left column click Advanced, then click the "Certificate" mini-tab on that panel, then click the "View Certificates" button. Individual site exceptions are on the "Servers" tab in the Certificate Manager. Ignore the ones with * for the address and find the sites you recall visiting. '''Before deleting it, please look at the Issuer." This will help in tracking down the explanation for needing to add exceptions. Perhaps it will be obvious from the Certificate Manager listing but, if not, click the certificate you added, then click the View button to call up the certificate viewer. I have attached an example of where to look for issuer information. Often this will point to a problem with Firefox not being fully set up to work with your security software, but there are other possible explanations as well.

Umnikazi wombuzo

Still uncertain why this happened, since I have been using this site regularly. All I find here is issued by Avast antivirus. No certificate found. I don't know if this is bad or not.

Still uncertain why this happened, since I have been using this site regularly. All I find here is issued by Avast antivirus. No certificate found. I don't know if this is bad or not.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Avast 2015 does have the option to intercept and filter your browsing. In order to be able to filter secure connections, Avast needs to insert itself into the middle and present fake site certificates to Firefox. You either can stop Avast from filtering secure connections, or set up Firefox to work with this feature, i.e., to trust the fake certificates that Avast signs.

If this was all working fine until recently, it's possible that you used Firefox's Refresh feature. In that process, your old settings folder (including the trust established with Avast) is moved to your desktop into an Old Firefox Data folder. Do you see anything like that?

Either way, Avast is supposed to set up Firefox automatically, but this may not always work. For the time being, it might be simplest to stop scanning secure connections. These steps are several months old, so apologies if Avast has changed...

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, you can still use the feature if you can get Firefox to trust Avast's signing certificate. You could try reinstalling Avast to trigger that process.

Avast 2015 does have the option to intercept and filter your browsing. In order to be able to filter secure connections, Avast needs to insert itself into the middle and present fake site certificates to Firefox. You either can stop Avast from filtering secure connections, or set up Firefox to work with this feature, i.e., to trust the fake certificates that Avast signs. If this was all working fine until recently, it's possible that you used Firefox's Refresh feature. In that process, your old settings folder (including the trust established with Avast) is moved to your desktop into an Old Firefox Data folder. Do you see anything like that? Either way, Avast is supposed to set up Firefox automatically, but this may not always work. For the time being, it might be simplest to stop scanning secure connections. These steps are several months old, so apologies if Avast has changed... #Open the Avast dashboard on the affected system. #Select Settings from the left sidebar menu. #Switch to Active Protection. #Click on Customize next to Web Shield. #Uncheck the "Enable HTTPS Scanning" option and click ok If that resolves the issue, you can still use the feature if you can get Firefox to trust Avast's signing certificate. You could try reinstalling Avast to trigger that process.

Okulungisiwe ngu jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
17407 izisombululo 157253 izimpendulo
Kuphostiwe

If you are on Windows 10 then you can check for issues with Microsoft Family Safety.

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

If you are on Windows 10 then you can check for issues with Microsoft Family Safety. *http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings *https://support.microsoft.com/en-us/kb/2965142 *[[/questions/1083592]] If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field of this window type or paste the URL of the website. *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.