Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I've followed instructions for setting default search engine but it WILL NOT get rid of yahoo (which I think I accidentally set when I downloaded C Cleaner upda

  • 4 uphendule
  • 8 zinale nkinga
  • 546 views
  • Igcine ukuphendulwa ngu frangipani47

more options

I use Firefox as my browser and it usually opens with google as home page and searches are via google. Suddenly it started opening on yahoo and also using that as search engine. I suspect it happened when I downloaded update of C Cleaner which I think has a box I should have unticked. I seem to have got the home page back BUT a new tab still opens in yahoo and searches immediately go to yahoo. I've clicked the options tag (from drop down box top right) and gone through all that several times but it keeps going back to yahoo!!! Please can anyone tell me how to get rid of it.

Isisombululo esikhethiwe

Hi, try this: Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.newtab.url and see what the exact URL is set to in 'Value', which may give a clue as to where it's coming from. It should be about:newtab which you can change by, right click > Modify, but it will most likely get changed back by whatever is affecting it. More - Configuration Editor for Firefox.

If you still can't find it, you can try these free programs to scan for malware, which work with your existing antivirus software:

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (4)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

more options

Thank you very much, fredmcd. Add ons manager is on Firefox start page for me and I found Extensions but no mention of Yahoo at all. Similarly no mention in list of programmes. I downloaded the Mozilla Search reset, I've messed about with internet options... and it still defaults to Yahoo when I open a new tab (via + sign at top) or search. It's very frustrating! But thank you anyway. I may have to live with it till a computer whizz comes to stay.

more options

Isisombululo Esikhethiwe

Hi, try this: Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.newtab.url and see what the exact URL is set to in 'Value', which may give a clue as to where it's coming from. It should be about:newtab which you can change by, right click > Modify, but it will most likely get changed back by whatever is affecting it. More - Configuration Editor for Firefox.

If you still can't find it, you can try these free programs to scan for malware, which work with your existing antivirus software:

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Thank you both very much indeed. In the end I'm not quite sure what worked but your suggestions sent me hunting round in places I otherwise would not have ventured into. The last thing which may just have confirmed the things I had been trying unsuccessfully to change was pressing the 'Refresh Firefox' button. I seem to be sorted - fingers crossed - so thank you very much for your help.