Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"About Firefox" not available in Firefox 39 & 40 on Mac

  • 4 uphendule
  • 2 zinale nkinga
  • 10 views
  • Igcine ukuphendulwa ngu smenjas

more options

On Windows and Linux, the "About Firefox" screen can be accessed via the "hamburger" icon in the top right of the browser.

On Macs, the "About Firefox" screen can only be accessed via the Firefox menu, in the Mac menu bar, next to the Apple menu.

In Firefox 38 (for Mac), the "About Firefox" option showed in the Firefox menu. In Firefox 39 & 40, there is only an option to quit.

On Windows and Linux, the "About Firefox" screen can be accessed via the "hamburger" icon in the top right of the browser. On Macs, the "About Firefox" screen can only be accessed via the Firefox menu, in the Mac menu bar, next to the Apple menu. In Firefox 38 (for Mac), the "About Firefox" option showed in the Firefox menu. In Firefox 39 & 40, there is only an option to quit.

All Replies (4)

more options

Did you check other menus like the Help menu where About can be found on other platforms?

Just to be sure:

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Neither the Help menu nor the newer hamburger menu have had an entry for "About Firefox" on the Mac. It's only ever been accessible via the Firefox menu.

I've filed a bug report for this issue here: https://bugzilla.mozilla.org/show_bug.cgi?id=1195049

My current workaround is to open a new tab and enter "about:" in the address bar. This lets me see the current version number, but doesn't let me check for updates, which is what I was looking for in the first place.

more options

I relaunched Firefox in safe mode, and I observed the same behavior.

more options

I'm using the default Firefox theme.