Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why do I keep seeing the its' personal ad with two girls?

  • 1 baphendule
  • 1 inale nkinga
  • 4 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

When I click the firefox logo on my taskbar and firefox homepage appears with a search box, I often times have a video ready to begin with conotations of it's personal. There are two girls dressed in white that will be involved in the video. I don't want to see the option of me seeing this video all day long just above the search bar. I want to see the large fox on my home page with the search box underneath it. If I continue to see this ad/potential video, I will get rid of mozilla firefox by uninstalling it. Right now, the home page stinks.

When I click the firefox logo on my taskbar and firefox homepage appears with a search box, I often times have a video ready to begin with conotations of it's personal. There are two girls dressed in white that will be involved in the video. I don't want to see the option of me seeing this video all day long just above the search bar. I want to see the large fox on my home page with the search box underneath it. If I continue to see this ad/potential video, I will get rid of mozilla firefox by uninstalling it. Right now, the home page stinks.

All Replies (1)

more options

The easiest way to get around that is to just set your own homepage and not use the "default" about:home page. See - How to set the home page


You can use this UserStyle - https://userstyles.org/styles/104673/about-home-hide-snippets-and-hide-brand-logo - to hide the two sections of the about:home homepage that Mozilla sends messages and videos to when they feel the "need".


Many of us have disabled the changes to the top part [brandLogo portion] of the Firefox Start Page and turned off the advertising "snippets" [below the Search container] that Mozilla is using all the time now, so that we don't see that "stuff".

If you feel venturesome, here's how to "fix it". Type about:config in the Location Bar and hit Enter. Accept the "dragons" message to see the advanced prefs screen. Use the Search field at the top to enter the pref mentioned below.

You can set the browser.aboutHomeSnippets.updateUrl pref to an empty string to stop your Firefox from retrieving "snippets" and brandLogo changes. Right-click that pref and select Modify then clear the Value for that pref in the box that appears, then click OK. That will also disable the "snippets" that appear below the Search container on the default homepage.

Then you need to open your Profile folder, via Help > Troubeshooting Information > Profile folder >> Show Folder button. Then close Firefox. With your Profile folder open and Firefox closed ("3-bar" Firefox menu button > Exit/Quit), wait minute or so, then delete the storage\moz-safe-about+home folder in the Firefox profile folder to remove the brandLogo and snippets stored in IndexedDB to make Firefox use the default brandLogo and a default snippet set.

Then restart Firefox for those changes to take effect.

If you should later change your mind about those modifications, you can reset the browser.aboutHomeSnippets.updateUrl pref via the right-click context menu and use Reset to get the default value back to start using the storage\moz-safe-about+home folder again.