Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Open search links in new tab

  • 6 uphendule
  • 12 zinale nkinga
  • 302 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Ever since the last "update" 33.1 then 33.1.1 I've been unable to just clink a link in a Google search and a new tab opens why? Is it because Firefox is no longer going to use Google as it's prime search engine and it's a sneaky way of getting people to use Yahoo?

All Replies (6)

more options

It could be that one of your preference changed. And to answer your question, no this is not the reason at all.

The preference to open a link in a new tab is to right click on the link an select "Open Link in New Tab" or the default checked option under Firefox Menu > Options > Tabs > "Open new windows in new tab instead" should be checked by default.

Does this happen in Safe Mode as well? Troubleshoot Firefox issues using Safe Mode

more options

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.


Separate Issue; Your System Details shows;

Installed Plug-ins

Adobe Shockwave for Director Netscape plug-in, version 12.1.1.151 Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148

Having more than one version of a program may cause issues.

Flash is notorious for not cleaning out the older version as part of an update. Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac Then reinstall the latest version.

Flash Player v15.0.0.223 http://get.adobe.com/flashplayer/ Shockwave Director v12.1.4.154 http://get.adobe.com/shockwave/

more options

Thanks for info on Adobe but problem with Google still exists...I'll just have to right click and learn to live with it.:-(

more options

Did you disable all added toolbars and anti-virus add-ons?

more options

I wonder if instead of this being a Firefox issue it is a change of your Google settings ?

Some links are designed to open in a new window, but most links on left click open in the current tab. That will happen for instance on your question page if you click a name link under an avatar.

The same will ordinarily happen on a web page of Google search results, however Google itself can modify that action, by its own settings, so that the link will open in a new Window (and in turn Firefox may be set to redirect that to a new tab instead of a new Window)

  • Use Google :
Cog -> Search Settings -> [] Open each selected result in a new browser window.   
( https://www.google.com/preferences? )
  • Firefox:
    • Key into the location bar about:preferences
      (Or use: menu -> cog)
    • |General (tab)| Check [] Open new windows in a new tab instead
    • SEE Tab preferences and settings
more options

I think you may find this very helpful;

MClickFocusTab {web link} While using mouse middle-click to open new tabs, with a short- time clicking to open new tabs in background, with a long-time clicking to open new tabs in foreground.