Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

No tab opens when I click on a link if any Firefox window is already open.

  • 11 uphendule
  • 2 zinale nkinga
  • 42 views
  • Igcine ukuphendulwa ngu outthere1000

more options

I updated to Firefox (desktop) 32 for Mac, and since then when I click on a link in an email, Firefox comes to the front but no new tab opens, as before, if there is any other window open in Firefox. The only way I can get the link to open is by closing any other Firefox window/s open. This is a major pain. Does anyone else have this problem, and if so, how can it be fixed?

All Replies (11)

more options

Try to redo the default browser setting and temporarily set another browser as the default browser. You may have to do this in the Safari Preferences.

more options

Thank you for your reply. Getting Firefox to work as my default browser is not the problem. The problem is: when I click on a link (eg in an email), Firefox comes to the front without problem (it's my default browser); but nothing more happens - no new tab - if I already have one or more tabs open. I have to shut all tabs first before the new link will open in a new tab. This has not happened in any previous version of Firefox - it's new to version 32.

more options

You seem to be running Firefox in Private Browsing mode.

  • browser.privatebrowsing.autostart: True

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"
more options

Other users noted that if Firefox was hidden in the dock, they had to click the link twice, once to unhide Firefox and again to actually load the link. Not sure if you have the same issue or that is a different issue.

more options

It's a different issue, but thank you for your reply.

more options

Thank you for your reply. If this is the only way to solve my problem, I think I shall switch to Safari as I wish to retain "never remember history". I'm also puzzled as to why this setting (which I've had for years) has not caused a problem in earlier versions of Firefox but (apparently) does now.

more options

Hi outthere1000, could you try the nonprivate just as a test? It might not actually make any difference, which would be useful to know in troubleshooting this.

more options

Hello, thanks again for your reply, As it turns out, I was already running "Use custom settings for history". So I guess "Never remember history" isn't the problem.

more options

You could try the Private Tab to get Private Browsing mode support per tab.

about:config page:

  • extensions.privateTab.allowOpenExternalLinksInPrivateTabs = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Okulungisiwe ngu cor-el

more options

Thanks for this. I'm not any sort of expert so I'm not clear what the above suggestion will do to save any time or solve my original problem. As things are now, I can simply copy the URL and paste it into a new tab and keep all my current settings - but what I want is for the old system of simply clicking on a link to get it to open in a new tab to work again.

more options

Further to jscher2000's suggestion yesterday: I think I misunderstood the suggestion, which I didn't find very clear. I've now discovered that if I send a Firefox open window (with one or more open tabs) to hide in the dock first, then clicking on a link twice (once to bring the mail program to the front and again to open the link), this will cause the hidden tab/s to come out of hiding AND a new tab for the link will open. Cumbersome, and I still maintain there is a bug in version 32, but this workaround is at least quicker than copying and pasting the link. Thanks to cor-el and jscher2000 for your responses.