Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox starts fast in safe mode, but slow in normal mode with all extensions and add-ons turned off.

  • 3 uphendule
  • 5 zinale nkinga
  • 2365 views
  • Igcine ukuphendulwa ngu ideato

more options

It's only the first screen/tab I open after firefox is completely shut off... it shows the borders of the screen for 5 seconds, before showing the content (empty page) and then I can start and everything after that is fine.

In safe mode it opens without delay, so my question is, what in the normal start-up could be causing this delay, I have reinstalled firefox, disabled all extensions and plugins.

Isisombululo esikhethiwe

Hello ellina, try disabling graphics hardware acceleration and check it again.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

In safe mode, also, hardware acceleration is disable, see : http://kb.mozillazine.org/Safe_mode

Thank you.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (3)

more options

Isisombululo Esikhethiwe

Hello ellina, try disabling graphics hardware acceleration and check it again.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

In safe mode, also, hardware acceleration is disable, see : http://kb.mozillazine.org/Safe_mode

Thank you.

more options

YES! thank you, totaly didn't see the "Hardware acceleration is disabled".

That did the trick, thanks again for your time.

more options

You are welcome