搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

why does Firefox open new tabs when HOME is clicked?

  • 6 回覆
  • 2 有這個問題
  • 68 次檢視
  • 最近回覆由 jscher2000

more options

I just upgraded to version 29.0 from a 4 year old version and I'm experiencing a problem that I can't imagine how to correct. I have two home pages set in my config, so that when I open firefox I get two tabs displayed. My Home Page field reads "https://www.google.com|https://news.google.com" When I open Firefox I get two tabs, one for Google and one for Google News.

On my old version, if I was in the first tab & navigated to www.hp.com and then later clicked HOME, Firefox would load that tab back to google. If I was in the second tab, it would navigate that tab back to google as well. The multiple Home page option was just a great help for initialization.

Now, regardless of what tab I'm in, when I click "HOME" Firefox opens two new pages, sets the first to my first home and the second to my second home and now I have FOUR tabs open. Click home again and I have 6 tabs, again and 8 tabs, etc.

There has to be a way to fix this. The HOME button is supposed to operate of the current focus, just as it does if you have a single home page specified.

所有回覆 (6)

more options

I never noticed whether the Home button opened only the first home page or all the home pages (I don't use multiple home pages).

On the new tabs point, you're right: the Home button, just like a bookmark, should open the first home page in the same tab unless you use Ctrl or Shift to divert it to a different tab or window.

Do you have any tab-related extensions installed that could be affecting the operation of the button?

more options

No extensions except for Foxit and QuickTime. Multiple Home Pages used to be the coolest thing ever. I can see a logical complication, of course. When you click "home" on a third tab, etc. but initializing 2 new pages? No. That's a mistake.

more options

Could you check your Extensions list again? I think Foxit and QuickTime are both plugins, so you may need to click around the Add-ons page to get to the list of Extensions.

Or you can extract it from the Troubleshooting Information page as follows. Either:

  • Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the upper left corner, click the Copy Text to Clipboard button and then you can paste into a reply. To omit the extra sections after the extensions, look for "Important Modified Preferences" and clear from there to the end.

more options

The default behavior since Firefox 4 (02-12-2011) regarding multiple homepages has been to open the first homepage in the tab that is active (regardless of its location in the tab strip) and to open new tabs for the 2nd and subsequent homepages.

more options

Opening multiple home pages when the program is invoked is a really cool feature, but most reasonable people would agree that the "home" button is supposed to bring the page in focus to the desired url and never open an additional tab. If I wanted another tab open, I'd open another tab. It makes the "HOME" button useless. This is the way the older version worked and it simply makes no sense for "home" to open new pages.

But if I read what you're saying, it doesn't matter and this behavior can't be altered? Another case of "it is what it is and if you don't like it use IE"?

more options

Hi Stan, what both Ed and I are saying is that the first of your home pages should open in the current tab you're viewing -- the way you want -- because that's what happens for us.

Could you repeat the test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?