X
點擊此處開啟此網站的行動版。

技術支援討論區

No longer able to hear audio on youtube videos

已張貼

Since upgrading to Firefox 23.0.1, I noticed I was having intermittent issues with no audio in Youtube videos. I have since discovered that, if I go to youtube to watch a video, there is no audio. The weird thing about this, though, if the video is linked through a forum, and I watch it embedded through that forum, it works fine.

Other video sites (test site linked in the FAQ and the videos on mozilla.org) work fine. If I open the youtube video in IE, it works fine.

I've tried searching these forums and the internet in general, but I'm not seeing anything similar.

Since upgrading to Firefox 23.0.1, I noticed I was having intermittent issues with no audio in Youtube videos. I have since discovered that, if I go to youtube to watch a video, there is no audio. The weird thing about this, though, if the video is linked through a forum, and I watch it embedded through that forum, it works fine. Other video sites (test site linked in the FAQ and the videos on mozilla.org) work fine. If I open the youtube video in IE, it works fine. I've tried searching these forums and the internet in general, but I'm not seeing anything similar.

被選擇的解決方法

Issue appears to be specific to flash. When I set my defaults to HTML5, any video that launches via HTML 5 works fine in Firefox. It's only when the video tries to launch via Flash that I had problems.

I went through and uninstalled the flash plug-in and removed flash from the PC, then did a clean reinstall. Whatever the problem was went away with a new install of flash.

從原來的回覆中察看解決方案 2

額外的系統細節

已安裝的外掛程式

  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.5.3.14917
  • Shockwave Flash 11.8 r800
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • ActiveTouch General Plugin Container Version 105
  • VLC media player Web Plugin 2.0.0-rc
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • 0.80.0
  • 0.70.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

應用程式

  • Firefox 23.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • 技術支援網址:http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

擴充套件

  • Anti-Banner 13.0.1.4307 (anti_banner@kaspersky.com)
  • ChatZilla 0.9.90.1 ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2})
  • Exif Viewer 2.00 (exif_viewer@mozilla.doslash.org)
  • Ghostery 5.0.4 (firefox@ghostery.com)
  • Greasemonkey 1.11 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • NoScript 2.6.7.1 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • RoboForm Toolbar for Firefox 7.9.0.0 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WebEx Productivity Tools 2.0 (ocplugin@webex.com)
  • Content Blocker 13.0.1.4307 (content_blocker@kaspersky.com) (Inactive)
  • Kaspersky URL Advisor 13.0.1.4307 (url_advisor@kaspersky.com) (Inactive)
  • Safe Money 13.0.1.4307 (online_banking@kaspersky.com) (Inactive)
  • Virtual Keyboard 13.0.1.4307 (virtual_keyboard@kaspersky.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce 8800 GTS 512
  • adapterDescription2:
  • adapterDeviceID: 0x0600
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 1-18-2013
  • driverDate2:
  • driverVersion: 9.18.13.1106
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 8800 GTS 512)
  • windowLayerManagerType: Direct3D 10

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.startup.homepage: about:newtab
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • font.internaluseonly.changed: True
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1378176531
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.mixed_content.block_active_content: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1377935945

其他

  • User JS: 否
  • 輔助功能: 是
Andrew
  • Moderator
321 個解決方法 4041 個答案

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

提出問題者

Started Firefox in safe mode, no sound on any of the youtube videos I selected. Just to make sure, I copy/pasted one of the links to IE and I had perfect audio.

Started Firefox in safe mode, no sound on any of the youtube videos I selected. Just to make sure, I copy/pasted one of the links to IE and I had perfect audio.
cor-el
  • Top 10 Contributor
  • Moderator
17483 個解決方法 158000 個答案

Did you check the volume setting in the player?

Try to delete the webappsstore.sqlite file to remove all local storage.
Otherwise local storage can only be cleared if you use Clear Recent History (Ctrl+Shift+Delete) to remove all cookies (i.e. time range is everything)

You can check if DOM Storage is enabled.

Did you check the volume setting in the player? Try to delete the webappsstore.sqlite file to remove all local storage.<br /> Otherwise local storage can only be cleared if you use Clear Recent History (Ctrl+Shift+Delete) to remove all cookies (i.e. time range is everything) You can check if DOM Storage is enabled. *http://kb.mozillazine.org/dom.storage.enabled

提出問題者

>> Did you check the volume setting in the player?

Yes, it's set at full volume. I can hear a static sound based on how high the volume is set, but no actual audio.

>>Try to delete the webappsstore.sqlite file to remove all local storage. Otherwise local storage can only be cleared if you use Clear Recent History (Ctrl+Shift+Delete) to remove all cookies (i.e. time range is everything)

Restarted firefox, hit ctrl+shift+delete, made sure ALL of the check boxes were marked and the time frame was set to Everything. Didn't resolve the issue.

>> You can check if DOM Storage is enabled.

Dom.storage.enabled is set to true. Set it to false, re-ran the above steps to clear all cache/cookies/storage, then tried again. Still not able to hear anything on youtube. Reset dom.storage.enabled back to true.

>> Did you check the volume setting in the player? Yes, it's set at full volume. I can hear a static sound based on how high the volume is set, but no actual audio. >>Try to delete the webappsstore.sqlite file to remove all local storage. Otherwise local storage can only be cleared if you use Clear Recent History (Ctrl+Shift+Delete) to remove all cookies (i.e. time range is everything) Restarted firefox, hit ctrl+shift+delete, made sure ALL of the check boxes were marked and the time frame was set to Everything. Didn't resolve the issue. >> You can check if DOM Storage is enabled. Dom.storage.enabled is set to true. Set it to false, re-ran the above steps to clear all cache/cookies/storage, then tried again. Still not able to hear anything on youtube. Reset dom.storage.enabled back to true.
megan237 0 個解決方法 2 個答案

Does anyone have a fix for this yet? I am running Firefox 24.0 . Have tried all above . Running latest flash and all other addons up to date. I have windows sounds and things like iPlayer work fine - but youtube no sound.

Does anyone have a fix for this yet? I am running Firefox 24.0 . Have tried all above . Running latest flash and all other addons up to date. I have windows sounds and things like iPlayer work fine - but youtube no sound.
mousemover 0 個解決方法 1 個答案

on my youtube screen in the lower left there is an icon for the sound and it is marked with an x on the right side ???

on my youtube screen in the lower left there is an icon for the sound and it is marked with an x on the right side ???

由 mousemover 於 修改

megan237 0 個解決方法 2 個答案

Yes there is! I can hear sound using IE and there is no x on youtube screen there. So what do I do?

Yes there is! I can hear sound using IE and there is no x on youtube screen there. So what do I do?
AliceWyman
  • Moderator
240 個解決方法 2594 個答案

有幫助的回覆

I copied this from a thread on Adobe's forum:

http://forums.adobe.com/message/5735126#5735126
sound not working on youtube


Ortho_Fan,
Oct 4, 2013 10:04 AM   in reply to chaleegeorge
I've see this identical issue posted on other help forums.  Seems that YouTube, itself, is having some issues. 
I just tried a video, and there was no sound.  Then, I noticed that there was an "X" next to the speaker icon. I hovered the cursor over the speaker, clicked on the slider, and moved the slider all the way to the right, and BAM, normal volume again.
From what I can tell, YouTube has set Muted Volume as the default.

I copied this from a thread on Adobe's forum: http://forums.adobe.com/message/5735126#5735126 <br> sound not working on youtube <br> ----- Ortho_Fan, Oct 4, 2013 10:04 AM in reply to chaleegeorge I've see this identical issue posted on other help forums. Seems that YouTube, itself, is having some issues. I just tried a video, and there was no sound. Then, I noticed that there was an "X" next to the speaker icon. I hovered the cursor over the speaker, clicked on the slider, and moved the slider all the way to the right, and BAM, normal volume again. From what I can tell, YouTube has set Muted Volume as the default. <img src="http://forums.adobe.com/servlet/JiveServlet/showImage/2-5735023-468534/youtubemute.jpg">
uptheirons 0 個解決方法 2 個答案

Dont know if it is the correct thread,but when i open my pc and then firefox the adobe flash player sounds in the mixer are muted everytime and i have to unmute it when i open firefox.Is there a fix about this?

Thanks in advance.

Dont know if it is the correct thread,but when i open my pc and then firefox the adobe flash player sounds in the mixer are muted everytime and i have to unmute it when i open firefox.Is there a fix about this? Thanks in advance.

提出問題者

No, it's not the mute problem that they're currently having.

When I checked the issue originally, audio is enabled and mute is not turned on in Youtube.

I do know about the mute issue and have seen it within IE, this pre-dates that issue.

No, it's not the mute problem that they're currently having. When I checked the issue originally, audio is enabled and mute is not turned on in Youtube. I do know about the mute issue and have seen it within IE, this pre-dates that issue.
AliceWyman
  • Moderator
240 個解決方法 2594 個答案

uptheirons (and anyone else having Flash audio problems on YouTube):

If the problem is muted sound in YouTube videos, this is a YouTube issue that's affecting Chrome and other browsers, as well as Firefox. See this post on Google's forum: http://productforums.google.com/forum/#!category-topic/youtube/report-a-technical-issue/ETfCgHO4MhU

If you're having a different issue, please ask a new question: https://support.mozilla.org/en-US/questions/new

'''uptheirons''' (and anyone else having Flash audio problems on YouTube): If the problem is muted sound in YouTube videos, this is a YouTube issue that's affecting Chrome and other browsers, as well as Firefox. See this post on Google's forum: http://productforums.google.com/forum/#!category-topic/youtube/report-a-technical-issue/ETfCgHO4MhU If you're having a different issue, please ask a new question: https://support.mozilla.org/en-US/questions/new
AliceWyman
  • Moderator
240 個解決方法 2594 個答案

rapozd2234,

I'm sorry to hear that your original problem (intermittent sound problem on YouTube) is still not solved. The best I can suggest is to

  1. Try the other solutions in Fix common audio and video issues
  2. Reset Firefox using the steps here: Refresh Firefox - reset add-ons and settings
'''rapozd2234,''' I'm sorry to hear that your original problem (intermittent sound problem on YouTube) is still not solved. The best I can suggest is to #Try the other solutions in [[Fix common audio and video issues]] #Reset Firefox using the steps here: [[Reset Firefox – easily fix most problems]]
cor-el
  • Top 10 Contributor
  • Moderator
17483 個解決方法 158000 個答案

有幫助的回覆

Did you check the volume setting for the plugin-container in the volume mixer via its icon on the Windows Task bar (notification area)?

uptheirons created a thread here: [/questions/973475]

Did you check the volume setting for the plugin-container in the volume mixer via its icon on the Windows Task bar (notification area)? ''uptheirons created a thread here: [[/questions/973475]]''

由 cor-el 於 修改

Schiavini 0 個解決方法 4 個答案

I am using Firefox 27 with YouTube HTML5 beta, and some videos have no sound. For example: http://www.youtube.com/watch?v=FdXh7wtlpI8 Some other videos do work, such as http://www.youtube.com/watch?v=iD9g6PvNOF4

Disabling the HTML5 option, the Flash option does work well.

I am using Firefox 27 with YouTube HTML5 beta, and some videos have no sound. For example: http://www.youtube.com/watch?v=FdXh7wtlpI8 Some other videos do work, such as http://www.youtube.com/watch?v=iD9g6PvNOF4 Disabling the HTML5 option, the Flash option does work well.
cor-el
  • Top 10 Contributor
  • Moderator
17483 個解決方法 158000 個答案

You can try to right-click an HTML5 video and open the controls if they do not appear automatically and check the volume setting in the built-in HTML5 media player.

You can try to right-click an HTML5 video and open the controls if they do not appear automatically and check the volume setting in the built-in HTML5 media player.

選擇的解決方法

Issue appears to be specific to flash. When I set my defaults to HTML5, any video that launches via HTML 5 works fine in Firefox. It's only when the video tries to launch via Flash that I had problems.

I went through and uninstalled the flash plug-in and removed flash from the PC, then did a clean reinstall. Whatever the problem was went away with a new install of flash.

Issue appears to be specific to flash. When I set my defaults to HTML5, any video that launches via HTML 5 works fine in Firefox. It's only when the video tries to launch via Flash that I had problems. I went through and uninstalled the flash plug-in and removed flash from the PC, then did a clean reinstall. Whatever the problem was went away with a new install of flash.
Schiavini 0 個解決方法 4 個答案

For me the issue was only with HTML5, never with Flash. However YouTube is not showing the mentioned videos in HTML anymore.

For me the issue was only with HTML5, never with Flash. However YouTube is not showing the mentioned videos in HTML anymore.
MickP2 0 個解決方法 1 個答案

I had the same problem on a Windows computer. What I found was that a process was still running after I'd closed Firefox. So when I re-opened Firefox the failing process was still in control.

This has typically happened to me when I unplug the headphones and want to hear from the speaker.

The quick way to tell if you have this problem is to hold down shift whilst starting Firefox (safe mode). It will then report that Firefox is still running.

To fix the problem go into Task Manager (Ctrl-Alt-Del) and close the firefox.exe process.

I had the same problem on a Windows computer. What I found was that a process was still running after I'd closed Firefox. So when I re-opened Firefox the failing process was still in control. This has typically happened to me when I unplug the headphones and want to hear from the speaker. The quick way to tell if you have this problem is to hold down shift whilst starting Firefox (safe mode). It will then report that Firefox is still running. To fix the problem go into Task Manager (Ctrl-Alt-Del) and close the firefox.exe process.

由 MickP2 於 修改