搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox doesn't play "embedded" youtube videos, but plays the videos on youtube.com

  • 7 回覆
  • 40 有這個問題
  • 22431 次檢視
  • 最近回覆由 ShmenI

more options

Firefox won't play youtube videos embedded on other sites, but plays the videos on youtube.com this only happens with youtube, and did not happen with non-youtube videos embedded in other websites, atleast not yet.

被選擇的解決方法

well, what solved it eventually was clearing cookies somehow I skipped that step during the time I spent figuring it out Thanks anyway everybody!

從原來的回覆中察看解決方案 👍 0

所有回覆 (7)

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

I'm afraid it didn't... I tried it first thing after I reset Firefox and it didn't do anything. Thanks for the help though :)

Also, I think it might be worth mentioning that embedded youtube videos work on other browsers, so i'm guessing I installed an extension or something of the sort that disabled it on firefox...

more options

I'm having a similiar issue. We've narrowed it down to Firefox 18 (though we've seen it sporadically on versions 16, 17) and only on Windows (on Vista, 7 & 8 - not sure about XP).

The issue is that some embedded YouTube clips will not load. When the page loads, all you see is a black box.

In some instances, reloading the page will finally get the video to load.

Here's a URL that seems to demonstrate the issue:

http://extramustard.si.com/2013/01/31/beyonce-sings-natioanl-anthem-at-super-bowl-press-conference/

more options

Also, I tested the following builds and here's the status of whether the exhibit the behavior or not:

Firefox 16.01: Works fine. Firefox 16.02 Works fine. Firefox 17: Does not play Firefox 18: Does not play. Firefox 19: Does not play. Latest nightly build: Does not play.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Also check that you aren't blocking cookies.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Note that a reset imports cookies, so isn't really suited if cookie issues are a possible cause, unless you clear the cookies.

由 cor-el 於 修改

more options

This issue may arise if you are trying to use the object or embed elements to play the video. The best way to do this cross-browser, and the current recommendation by Google, is to use an iframe.

An example for embedding playlists:

<iframe src='http://www.youtube.com/embed/videoseries?list=PLFE11CE11D5EA7D87' allowfullscreen frameborder='0'></iframe>

An example for embedding a single video:

<iframe src='http://www.youtube.com/embed/C6WKYAZXlCA?modestbranding=1&rel=0' allowfullscreen frameborder='0' ></iframe>

more options

選擇的解決方法

well, what solved it eventually was clearing cookies somehow I skipped that step during the time I spent figuring it out Thanks anyway everybody!