搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox will not play Netflix

  • 4 回覆
  • 12 有這個問題
  • 17660 次檢視
  • 最近回覆由 mbrady1960

more options

Netflix movies play using Safari, but not Firefox. Using Firefox 15.0.1, Mac OS 10.7.5, and Sliverlight 5.1.10411.0, when I try to play a Netflix movie, it ask me to download Silverlight again. After doing so, it still does not play movie and asks for Silverlight download again.

被選擇的解決方法

Problem was solved by moving the previously downloaded version of Silverlight to the trash, emptying the trash, then downloading Silverlight a second time.

從原來的回覆中察看解決方案 👍 4

所有回覆 (4)

more options

I wonder whether this is the 32-bit/64-bit issue. Could you check this thread and see whether that makes any difference for you: Firefox does not play netflix.

more options

選擇的解決方法

Problem was solved by moving the previously downloaded version of Silverlight to the trash, emptying the trash, then downloading Silverlight a second time.

more options

I had this problem Netflix too. Here's a sure fix for MAC users:

  1. Access your hard drive (double click the hard drive icon in finder)
  2. Find the silverlight plugin (navigate to your Internet Plug-Ins directory: /Library/Internet Plug-Ins/)
  3. Remove the silverlight plugin (drag any of the following into your trash bin:
      * Silverlight.plugin 
      * WPFe.plugin
  1. Empty your trash bin
  2. Go to www.microsoft.com/getsilverlight/ using your Firefox browser.
  3. Download and install silverlight
  4. Restart Firefox

This removes a bad install of Silverlight and starts fresh. Definitely works!

more options

I am using Windows 7 64bit Ultimate and for some reason I had a problem that I have seen many people on here was having and was blaming Firefox's Plugin Container when watching Netflix or anything using Microsoft's Silverlight. But it isn't the Container that is causing the "Silverlight Plugin Has Crashed" problem. I just talked to Microsoft about it and found the solution on fixing it. The problem is the Computer Browser.

You go to "run", then type in "SERVICES.MSC" when that pops up scroll down to "Computer Browser" highlight it then in the left hand side at the top you will see "Restart the service". That's it. Restart computer. Now Firefox will play Silverlight.

I have read so many posts about this with people coming up with all sorts of things to try to fix this, but none has worked....for me anyway.

So do this and I'm sure you'll be happy again.