X
點擊此處開啟此網站的行動版。

技術支援討論區

Avast detects URL:MAL when opening firefox.No issue with IE or Chrome,after troubleshooting realized problem is NoScript addon.Can it have been infected?

已張貼

avast -network shield

Infection Details

URL: http://188.24.140.190/ Process: C:\Program Files (x86)\Mozilla Firefox\firefox.exe Infection: URL:Mal

avast -network shield Infection Details URL: http://188.24.140.190/ Process: C:\Program Files (x86)\Mozilla Firefox\firefox.exe Infection: URL:Mal

被選擇的解決方法

I doubt the No script addon got infected. However, try the following:

First, try to reset Firefox. Refresh Firefox - reset add-ons and settings. This simple step will eliminate many Firefox problems with only one click.

Download and Install MalwareBytes Anti-Malware, run a full Scan. http://www.malwarebytes.org/. This helps check that there are no viruses on your computer causing issues. You can uninstall this program after you clean off any infections.

從原來的回覆中察看解決方案 1

額外的系統細節

這發生了

每當開啟 Firefox 的時候

問題發生於...

Today

已安裝的外掛程式

no script

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

更多資訊

Initially after some troubleshooting I noticed that I could make infection pop up disappear:
TOOLS-> OPTIONS -> ADVANCED ->Configure how firefox connects to the internet -> changed from "use system proxy settings" to "auto-detect proxy settings" or "no proxy"
With this option changed the pop up from avast didn't appear any longer when opening Firefox.
However I noticed that both Chrome and IE were set to work on the same "use system proxy settings" and they weren't causing problems...so I assumed the problem still has to be with Firefox.
After changing back the option in Firefox to "use system proxy" I got again the notice, but saw that when opening Firefox in safe mode the issue was gone again.
I tracked it to the no script addon, after removing it, the issue disappear regardless of proxy config settings.
I am now running in depth virus scans to see if I can get rid of the actual cause.
P.S: If I re-install no script problem is back, as far as I can see I have an infection that is exploiting a vulnerability in this addon, which is designed exactly to increase reliability against attacks.

Tyler Downer
  • Top 25 Contributor
  • Moderator
1535 個解決方法 10703 個答案

選擇的解決方法

I doubt the No script addon got infected. However, try the following:

First, try to reset Firefox. Refresh Firefox - reset add-ons and settings. This simple step will eliminate many Firefox problems with only one click.

Download and Install MalwareBytes Anti-Malware, run a full Scan. http://www.malwarebytes.org/. This helps check that there are no viruses on your computer causing issues. You can uninstall this program after you clean off any infections.

I doubt the No script addon got infected. However, try the following: First, try to reset Firefox. [[Reset Firefox – easily fix most problems]]. This simple step will eliminate many Firefox problems with only one click. Download and Install MalwareBytes Anti-Malware, run a full Scan. [http://www.malwarebytes.org/ http://www.malwarebytes.org/]. This helps check that there are no viruses on your computer causing issues. You can uninstall this program after you clean off any infections.

提出問題者

Hi Tyler, Thanks for quick reply

Initially after some troubleshooting I noticed that I could make infection pop up disappear:

From Configure how firefox connects to the internet -> changed from "use system proxy settings" to "auto-detect proxy settings" or "no proxy"

With this option modified, the pop up from avast didn't appear any longer when opening Firefox.

However I noticed that both Chrome and IE were set to work on the same "use system proxy settings" and they weren't causing problems...so I assumed the problem still has to be with firefox.

After changing back the option in firefox to "use system proxy" I got again the notice, but saw that when opening firefox in safe mode the issue was gone again.

I tracked it to the no script addon, after removing it, the issue disappear regardless of proxy config settings...when I reinstall it, it appears again.

I am now running in depth virus scans to see were the actual infection is.

It seems to me it is expoiting a vulnerability in this addon, I will try the reset also.

Hi Tyler, Thanks for quick reply Initially after some troubleshooting I noticed that I could make infection pop up disappear: From Configure how firefox connects to the internet -> changed from "use system proxy settings" to "auto-detect proxy settings" or "no proxy" With this option modified, the pop up from avast didn't appear any longer when opening Firefox. However I noticed that both Chrome and IE were set to work on the same "use system proxy settings" and they weren't causing problems...so I assumed the problem still has to be with firefox. After changing back the option in firefox to "use system proxy" I got again the notice, but saw that when opening firefox in safe mode the issue was gone again. I tracked it to the no script addon, after removing it, the issue disappear regardless of proxy config settings...when I reinstall it, it appears again. I am now running in depth virus scans to see were the actual infection is. It seems to me it is expoiting a vulnerability in this addon, I will try the reset also.

提出問題者

Managed to fix issue, after in depth scan with avast free edition detected and deleted 23 infections.

I am all clean now, installed noscript back and no more issues.

Managed to fix issue, after in depth scan with avast free edition detected and deleted 23 infections. I am all clean now, installed noscript back and no more issues.