搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I updated to FF12.0 My bookmarks toolbar and my homepage shows as blank every time I restart Firefox.

  • 4 回覆
  • 28 有這個問題
  • 37 次檢視
  • 最近回覆由 NoahSUMO

more options

When I disable the toolbar and then reenable it then all the bookmarks are still there but each time I restart firefox then the too bar (even though it is enabled) shows as blank until I kill it and bring it back again. Additionally, even though my homepage shows as correct in the options it does not load when I start Firefox.

被選擇的解決方法

Could you try disabling the All-in-One Sidebar add-on? Then closing Firefox and reopening it. I've heard from at least one person that disabling this add-on fixes the disappearing bookmarks toolbar for them. I'm not sure if it will also get rid of the homepage not loading but it might.

To disable All-in-One Sidebar:
Firefox button > Add-ons > Extensions or Tools > Add-ons > Extensions

Then click on All-in-One Sidebar, then click the Disable button. The words "Restart now" should appear above the disable button. Click on "Restart now" and let us know the results.
Screenshot:

從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options

Try:

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

選擇的解決方法

Could you try disabling the All-in-One Sidebar add-on? Then closing Firefox and reopening it. I've heard from at least one person that disabling this add-on fixes the disappearing bookmarks toolbar for them. I'm not sure if it will also get rid of the homepage not loading but it might.

To disable All-in-One Sidebar:
Firefox button > Add-ons > Extensions or Tools > Add-ons > Extensions

Then click on All-in-One Sidebar, then click the Disable button. The words "Restart now" should appear above the disable button. Click on "Restart now" and let us know the results.
Screenshot:

more options

Well fancy that...disabling the all in one sidebar and restarting not only brought my toolbar back up correctly but it brought back my history and my tabs from weeks ago before I updated... I suppose it's not compatible with the latest version. I may have to either ditch that or stop running the beta... know any reason why it doesn't seem to be compatible with 12?

more options

All I can say is that there must of been a technical change in the Firefox 12 code that was big enough to break All-in-One Sidebar.

If I were you I'd report these issues to the author asap so he can get a head start on fixing this in time for Firefox 12.

On his addon page, he says he likes to be contacted at his forums on his personal website: http://firefox.exxile.net/forum/index.php

Use the Bugs & Questions link under the All-in-One Sidebar section. You should report all the things All-in-One Sidebar broke and your version of Firefox.

Most likely the reason he hasn't updated is because he doesn't have time to work on it.

Aha! Looks like my theory was right. :D I found this tweet on his Twitter page:

And on 3/29/12, it looks like he's ready to work on it:
http://twitter.com/#!/AddonLab/status/185454890561183744

But to be on the safe side I still would report the issues in his forums, so he doesn't miss anything.