搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

When Firefox is on, Desktop Window Manager consumes a lot of RAM

  • 4 回覆
  • 2 有這個問題
  • 100 次檢視
  • 最近回覆由 unavailable

more options

I have multiple monitors and most often have Firefox windows open on each. Lately, I've been noticing that the Desktop Window Manager process is consuming a huge amount of RAM. At the same time, consumption completely disappears with the closing of Firefox windows. Video: https://i.imgur.com/pHCa7Hh.mp4 (I left it for a while then closed Firefox windows) After a while, I noticed that already 13 GB of memory is being used by DWM. I don't know if sites affect behavior, but most often I have https://music.yandex.ru/home open

OS: Windows 11 (Microsoft Windows [Version 10.0.22621.1928]). Firefox: 115.0.1 (64-bit) Screen setup: 1 - 3840 x 2560 with 200% scale, 2 - 1920 x 1080 with 100% scale.

I have multiple monitors and most often have Firefox windows open on each. Lately, I've been noticing that the Desktop Window Manager process is consuming a huge amount of RAM. At the same time, consumption completely disappears with the closing of Firefox windows. Video: https://i.imgur.com/pHCa7Hh.mp4 (I left it for a while then closed Firefox windows) After a while, I noticed that already 13 GB of memory is being used by DWM. I don't know if sites affect behavior, but most often I have https://music.yandex.ru/home open OS: Windows 11 (Microsoft Windows [Version 10.0.22621.1928]). Firefox: 115.0.1 (64-bit) Screen setup: 1 - 3840 x 2560 with 200% scale, 2 - 1920 x 1080 with 100% scale.
附加的畫面擷圖

被選擇的解決方法

It does not! And I disabled "Use hardware acceleration when available", now there is no memory consumption.

Seems like hardware acceleration is a culprit

從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options

I don't think it's OK

more options

Bump, still not fixed.

Appears only when I move the Firefox window to the built-in display (1920x1080 with 100% scale)

more options

Does it also happen in Troubleshoot Mode?

more options

選擇的解決方法

It does not! And I disabled "Use hardware acceleration when available", now there is no memory consumption.

Seems like hardware acceleration is a culprit