搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Right click and paste not available in Outlook web application on Firefox.

more options

I have been using Firefox as my preferred browser for years. Recently I notice that when using Outlook mail in web the paste option is gone when replying to an email. Everything works in Chrome and Edge correctly but not Firefox. I instead get a text toolbar and an option to insert an emoji. Note this is ONLY if I am replying to an email. In new emails I am able to use the file toolbar and paste from there. Any help would be appreciated as I would like to keep using Firefox. I have tried all the online remedies including clearing the cache to no avail.

Charles

I have been using Firefox as my preferred browser for years. Recently I notice that when using Outlook mail in web the paste option is gone when replying to an email. Everything works in Chrome and Edge correctly but not Firefox. I instead get a text toolbar and an option to insert an emoji. Note this is ONLY if I am replying to an email. In new emails I am able to use the file toolbar and paste from there. Any help would be appreciated as I would like to keep using Firefox. I have tried all the online remedies including clearing the cache to no avail. Charles
附加的畫面擷圖

所有回覆 (4)

more options

Does Ctrl+V work to paste ?

Any relevant-looking messages in the Web Console ?

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Thanks for your reply. It was helpful but unfortunately not conclusive. Firstly Cntrl+V does work. It's just the right button click that does not. In Troubleshoot mode and normal restart I can paste with a right click once only. Thereafter the dialog box changes and just shows the emoji option.

more options

MODERATOR NOTE:

Recommendations to flip dom.events.testing.asyncClipboard to true are a fundamentally bad idea. This pref was meant for automated testing, and bypasses all security/permission checks on clipboard access.

If you toggle this pref, any site has full access to your clipboard all the time without asking you or you even noticing so we suggest that you do not touch that pref.


Had the same problem with firefox and outlook web.

My solution was:

   open "about:config" in firefox (type it in the webadress line and hit enter)
   accept the risk in the pop up
   type "clipboard" in the search line
   change the following settings (as shown in the image attachment) from false to true (klick on false)
   restart firefox (close it & open it again)

由 Paul 於 修改

more options

Thanks for your reply. Unfortunately the changes mad no difference. Best C