搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Print <ctrl-P>... Preparing Preview hangs

more options

I'm running v100.0.1 (64-bit) on Win10. I've seen others report this problem but haven't found a fix listed anywhere. <Ctrl-P> or Menu->Print results in the same problem. The print overlay starts up (say Print in top right corner), spinning wheel above Preparing Preview in the center of the overlay... Never ends. I have to Esc to get out of it. Happens on any page. Print dialogue works fine on same pages with Chrome and Edge.

I'm running v100.0.1 (64-bit) on Win10. I've seen others report this problem but haven't found a fix listed anywhere. <Ctrl-P> or Menu->Print results in the same problem. The print overlay starts up (say Print in top right corner), spinning wheel above Preparing Preview in the center of the overlay... Never ends. I have to Esc to get out of it. Happens on any page. Print dialogue works fine on same pages with Chrome and Edge.
附加的畫面擷圖

被選擇的解決方法

FYI, I was able to correct this by: - deleting the HP Smart Print app - deleting the HP printer devices - setting Microsoft PDF as the default printer - tried the Ctrl-P in Firefox and it worked - Re-installed HP Smart print app (which re-installed HP printer devices) - tried the Ctrl-P in Firefox and it continued to work

從原來的回覆中察看解決方案 👍 1

所有回覆 (8)

more options

What Addons are you using?

有幫助嗎?

more options

Dropa said

What Addons are you using?
I have disabled all Addons.

有幫助嗎?

more options

The screenshot shows they are active?

有幫助嗎?

more options

Hi Bryan, could you try clearing some printer settings in case those are causing the problem. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste printer_ and pause while the list is filtered

Firefox will display numerous settings it has stored for each printer.

(3) Clear the non-customized settings by clicking the trash can at the right end of each row. By non-customized I mean you haven't manually edited the setting here, although you might have checked or unchecked a box on the settings panel. If there is something you edited manually, like changing the content of headers and footers, no need to delete those since those are not system printer settings.

The next time you print, Firefox should query MacOS for printer settings information and hopefully that will help in getting the preview working.

有幫助嗎?

more options

Dropa said

The screenshot shows they are active?
Some were active when I took the screenshot but I also ran turning each addon off one at a time. No change. Still didn't work.

有幫助嗎?

more options

jscher2000 - Support Volunteer said

Hi Bryan, could you try clearing some printer settings in case those are causing the problem. Here's how: .... The next time you print, Firefox should query MacOS for printer settings information and hopefully that will help in getting the preview working.
Thanks. I tried that and deleted 40 - 50 modified parameters. Shut FF down, restarted FF but no luck.

有幫助嗎?

more options

選擇的解決方法

FYI, I was able to correct this by: - deleting the HP Smart Print app - deleting the HP printer devices - setting Microsoft PDF as the default printer - tried the Ctrl-P in Firefox and it worked - Re-installed HP Smart print app (which re-installed HP printer devices) - tried the Ctrl-P in Firefox and it continued to work

有幫助嗎?

more options

Thanks for reporting back with your solution!

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題