搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Custom (System installed) fonts in Firefox?

  • 20 回覆
  • 1 有這個問題
  • 26 次檢視
  • 最近回覆由 jscher2000

more options

I have some fonts that I have installed through normal methods. They are all ttf files. However, they do not show up in the firefox change fonts dialog box. Even many pre-installed fonts do not show up. Websites are only able to use the local fonts listed in this dialog box. How will I then be able to use those fonts?

被選擇的解決方法

I found it privacy.resistFingerprinting was the reason I had set it to true, but now I reset it and the fonts work

從原來的回覆中察看解決方案 👍 0

所有回覆 (20)

more options

Websites generally use custom fonts, not the ones from your system. System fonts are only fallbacks in case website's fonts fail to load.

If you want to use your font on Firefox's user interface, then not every font is suitable for that thus not all of them are available.

有幫助嗎?

more options

What I mean to say is to set the fallback fonts i.e. serif font, sans-serif font, monospace font. It also helps load times if the font is available locally. Instead of choosing from a small list available currently in firefox.

有幫助嗎?

more options

There is a privacy-related font setting that might have been customized. To check its status, you'll need to go behind the scenes:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste layout.css.font-visibility and pause while the list is filtered

This group of preferences has three valid values:

  • 1 - only show/use base system fonts
  • 2 - also show/use fonts from optional language packs
  • 3 - also show/use user-installed fonts [default]

Note: before Firefox 94

(3) If you need to edit the value of this preference, double-click the layout.css.font-visibility.level preference (or click the pencil button) to display an editing field, and choose a lower value, then press Enter or click the blue check mark button to save the change.

Note: starting in Firefox 94

(3) If you need to edit the value of this preference, double-click the layout.css.font-visibility.standard preference (or click the pencil button) to display an editing field, and choose a lower value, then press Enter or click the blue check mark button to save the change.

To return to the default value at any time, click the Reset button at the right end of the row (looks like an arching back arrow).

由 jscher2000 於 修改

有幫助嗎?

more options

I checked the value, it is 3 but the fonts are still not showing up.

有幫助嗎?

more options

I found the font.name-list family of settings in about:config that seem to include lists of fonts, but modifying those seemed to do nothing.

有幫助嗎?

more options

Security sandbox restrictions may prevent Firefox from using font files saved in exotic folders in web content.

Can you spot a pattern to which folders the fonts not "seen" by Firefox are in? For example, if you open the Windows 10 Font Settings panel (type font in the system search box on the Taskbar for a quick link), click a font missing from Firefox and check its location on disk.

有幫助嗎?

more options

All the fonts are in C:\Windows\Fonts folder only. The only pattern I found was that no variable fonts were included. However many fonts which are not variable were also not included.

有幫助嗎?

more options

I can't think of any other relevant settings off the top of my head.

One method to suss out an issue with settings or add-ons is:

New Profile Test

This takes about 3 minutes, plus the time to test the Fonts dialog.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like Oct2021, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to Oct2021 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test.

Do different fonts show up in the Fonts dialog?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Oct2021 will remain available for future testing.)

有幫助嗎?

more options

Yes all the fonts do show up in the new profile

有幫助嗎?

more options

In fact, I checked with an old profile, and all the fonts show up there as well. It seems only this profile is affected.

有幫助嗎?

more options

It seems that signing in with my firefox account is the problem.

有幫助嗎?

more options

What 'font' prefs are displayed if you tick the "Show only modified preferences" box on the about:config page ?

有幫助嗎?

more options

Arnav Bhate said

It seems that signing in with my firefox account is the problem.

That's interesting. I have one profile that I sync with an Android device and it seems to list the same motley assortment of Windows fonts in the Fonts dialog as my regular profile. Maybe mobile OS isn't a relevant factor. Do you sync your Windows Firefox with Firefox running on MacOS or Linux?

有幫助嗎?

more options
Do you sync your Windows Firefox with Firefox running on MacOS or Linux?

I only have one windows 10 device, 2 android 11 devices and a android 5.1.1 device. Maybe the android 5.1.1 device might be a problem?

有幫助嗎?

more options

cor-el said

What 'font' prefs are displayed if you tick the "Show only modified preferences" box on the about:config page ?

有幫助嗎?

more options

Arnav Bhate said

Do you sync your Windows Firefox with Firefox running on MacOS or Linux?

I only have one windows 10 device, 2 android 11 devices and a android 5.1.1 device. Maybe the android 5.1.1 device might be a problem?

It was not a problem. I signed out of it and still no change. Signing in to my firefox account does irreversible damage on the font list.

由 Arnav Bhate 於 修改

有幫助嗎?

more options

I reinstalled firefox and now I am able to change to all fonts. Edit: While I am able to change, the fonts still don't work

由 Arnav Bhate 於 修改

有幫助嗎?

more options

Based on this entire thread, it seems that signing in to your Firefox account causes the problem. One possible reason is that it synchronizes a setting which disables the fonts. But I can't think of any settings we haven't already discussed. If you are handy with files, you could do a text comparison between the prefs.js file in the folder of a working profile and your broken profile. You can open the "Root directory" of each profile from the about:profiles page. For text comparison, I generally use the WinMerge program (from https://winmerge.org/). There will be a lot of differences in time stamps and calculated values to ignore. Only ones related to fonts, privacy and security are likely to be relevant.

有幫助嗎?

more options

選擇的解決方法

I found it privacy.resistFingerprinting was the reason I had set it to true, but now I reset it and the fonts work

有幫助嗎?

more options

Thank you for reporting back. That one should have been on my list, but I didn't notice that you identified your Firefox version as 93 while your user agent string indicated Firefox 91, which would have pointed us in that direction.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題