搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox not playing any audio whatsoever

  • 8 回覆
  • 3 有這個問題
  • 65 次檢視
  • 最近回覆由 TNorth

more options

Hello. Starting yesterday, Firefox has stopped playing audio from every website and even local files. Yes, I read this article and no, the sound is not being muted instead the sound just refuses to play. In the screenshot, it shows that the "play" "mute" and speed option are greyed out. Also, I tried using safe mode and audio still wouldn't play. What should I do?

附加的畫面擷圖

所有回覆 (8)

more options

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

This usually means that the media file is not a valid link or Firefox isn't able to play the file for other reasons. You can check the Web Console for media related messages.

有幫助嗎?

more options

In the web console i get the error:

Media resource file:///{FILEPATH} could not be decoded, error: Error Code: NS_ERROR_DOM_MEDIA_MEDIASINK_ERR (0x806e000b)
Details: OnMediaSinkAudioError {FILENAME}.mp3

有幫助嗎?

more options

Can I get some help anyone?

由 Computer 於 修改

有幫助嗎?

more options

And here's all the errors and warnings i get when watching a youtube video:

downloadable font: download failed (font-family: "Roboto" style:normal weight:500 stretch:100 src index:0): status=2152398850 source: https://fonts.gstatic.com/s/roboto/v29/KFOlCnqEu92Fr1MmEU9fABc4EsA.woff2
downloadable font: download failed (font-family: "Roboto" style:normal weight:400 stretch:100 src index:0): status=2152398850 source: https://fonts.gstatic.com/s/roboto/v29/KFOmCnqEu92Fr1Mu5mxKOzY.woff2
Some cookies are misusing the recommended “SameSite“ attribute 4
Failed to get service worker registration(s): Storage access is restricted in this context due to user settings or private browsing mode. desktop_polymer.js:12432:83
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at data:text/plain;base64,Cg==. (Reason: CORS request not http).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://googleads.g.doubleclick.net/pagead/id. (Reason: CORS request did not succeed).
Will-change memory consumption is too high. Budget limit is the document surface area multiplied by 3 (69115 px). Occurrences of will-change over the budget will be ignored. watch
MouseEvent.mozPressure is deprecated. Use PointerEvent.pressure instead. base.js:1325:347
Source map error: Error: request failed with status 404
Resource URL: https://www.youtube.com/watch?v=jNQXAC9IVRw
Source Map URL: yt-live-chat-default-theme.css.map
Loading failed for the <script> with source “https://static.doubleclick.net/instream/ad_status.js”. watch:1:1
Failed to register/update a ServiceWorker for scope ‘https://www.youtube.com/’: Storage access is restricted in this context due to user settings or private browsing mode. desktop_polymer.js:12459:132
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at data:text/plain;base64,Cg==. (Reason: CORS request not http).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://googleads.g.doubleclick.net/pagead/id. (Reason: CORS request did not succeed).

I really need help here. No one is responding

有幫助嗎?

more options

I finally found someone with my same problem that kinda hasn't relolved it yet, but maybe they can explain my problem better than i can...

有幫助嗎?

more options

So there is no solution to this yet?

I have the same issue. I just upgraded to Win11 and a new computer. Reinstalled the latest Firefox after dl from the mozilla site.

I usually use a Bose Color Soundlink paired via bluetooth to be my computer speaker. It works. I test it. It is listed as the default, paired speaker for output. It plays system files. It plays mp3s I click on from my hard drive.

But go to YouTube or any other website and click on a video, you get video, no SOUND. At all. Yes, I've made sure the sound slider is all the way up. I have paired and unpaired. The speaker works. Just not with Firefox. As a last test, I opened Microsoft edge. YouTube worked normally.

So, any solutions yet?

由 monsieurms 於 修改

有幫助嗎?

more options

Well, I think I fixed the problem. Using the tip to explore permissions, I clicked on the lock icon and gave Firefox permission to USE THE MICROPHONE. I don't actually have a microphone on this computer so that did not occur to me to do. It was a shot in the dark, but I tried it and that seems to have fixed it. Apparently, FF thinks the bluetooth speaker is a microphone. (It has no microphone.)

由 monsieurms 於 修改

有幫助嗎?

more options

I have read elsewhere about such an issue being fixed by disabling hardware acceleration. The relevant setting is on the General page of Settings. https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration

You could also try Troubleshoot Mode. https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題