搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Problem with embedded video i frame on firefox only.

  • 13 回覆
  • 1 有這個問題
  • 50 次檢視
  • 最近回覆由 azalewski

more options

Hello i have a problem with view video on my website. Other browsers like chrome, opera, edge works fine, the problem only exists on Firefox. I've tried many things like turning off extensions and site protections, turning off "Use hardware acceleration when available" option, i even allowed autoplay videos and sounds on every site, and problem still isn't solved. You guys have any ideas what's wrong, in older versions of firefox everything worked fine. Here's link: https://www.uczelnie.pl/miasto/warszawa/uczelnia/277/akademia-leona-kozminskiego-alk

所有回覆 (13)

more options

This page has a lot of issues. Your video is hidden within a div declared with class="test" and style="display: none". It would never work.

有幫助嗎?

more options

TyDraniu powiedział

This page has a lot of issues. Your video is hidden within a div declared with class="test" and style="display: none". It would never work.

Yes but there's a condition (if video error ---> change to display: none) but as i said on chrome, opera, edge it works perfectly, so i think something is wrong with firefox

有幫助嗎?

more options

I can see top part of this video after disabling Tracking protection and allowing Sound & video permission.

有幫助嗎?

more options

Hmmm, i know why he's so small there's anonther script that reads size from database it's depending on video resoultion ratio. But in my browser there's no option button near link, so i manually tried to allow/block video+sound ---> no results it's like browser doesn't know there's video to run.

有幫助嗎?

more options

Try to click the shield icon in the URL bar and turn off Enhanced tracking protection for this site.

有幫助嗎?

more options

No difference, tried it many times and no results :/

有幫助嗎?

more options

Works on mobile phone after allow autoplay videos, but still doesn't work on PC, however i'd like to change it other way. I mean i want random firefox user to watch it :/

有幫助嗎?

more options

That's my version of firefox

有幫助嗎?

more options

OK, perhaps someone else could suggest something. Please remove the "Chosen solution" flair from above post. Your issue is not resolved yet.

有幫助嗎?

more options

I see the video in Nightly (92) and in Beta/DE (91) with the default "Block audio" settings, but not in 89/90.

有幫助嗎?

more options

Yea i think something is wrong with this version, because as i remember, before update video player was OK. I think i have to just wait till 91/92 will be released.

有幫助嗎?

more options

Today at morning i had update on firefox developers to 91.0b2 and normal firefox to 90.0. Developers works, but normal still not working :/

有幫助嗎?

more options

There's still a problem with it, any ideas?

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題