搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Videos and GIF files do not play

  • 2 回覆
  • 1 有這個問題
  • 2 次檢視
  • 最近回覆由 cor-el

more options

This happened very suddenly, and in firefox as well as opera browser. Video files and GIFs display as moving vertical colored lines, like aurora borealis. This only applies to files embedded in mails, messenger or social sites, not sites like youtube - those play just fine. Video and GIF files saved in my desktop are fine as well. Issue arose about a week ago, I am stumped! Any suggestions?

所有回覆 (2)

more options

Do you recall going into about:config and turning on the privacy.resistFingerprinting feature? It blurs images extracted from a canvas, so it can show up in odd places.

If you have enabled that feature and want to keep using it:

While you are on a problem site, is there a canvas permission icon toward the left end of the toolbar? If so, you can use that to give the site permission to extract images from a canvas without blurring.

If there's no icon for it, try the Page Info dialog. While you are on the relevant page, you can call that up using either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Near the top, you'll find "Extract Canvas Data" and you can uncheck the "Use default" box and select the Allow permission. (Note: this permission only appears if privacy.resistFingerprinting has been enabled.)

That change is saved immediately. You can close Page Info and it should be effective on your next upload.

Was that it?

有幫助嗎?

more options

If you would have enabled "Resist Fingerprinting" then your user agent would have changed to Firefox 78 (current ESR), but since this is still 85 (current release) this could indicate something else is going on.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題