搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

When open saved bookmark in new tab, it swithes to it immediately. How to open it in background?

  • 3 回覆
  • 1 有這個問題
  • 533 次檢視
  • 最近回覆由 cor-el

more options

Hi, everyone!

I found a similar solution but only for "Open link in new tab": you can go to about:config and change the preference named browser.tabs.loadBookmarksInBackground. But I want the same thing for my saved bookmarks on Bookmarks Toolbar. Sometimes I need to open a few bookmarks from one folder and then I used for it middle-click or click on Open in new tab, but it switches to tab immediately and I should repeat a process again: click on a folder, find a bookmark, click on it, new tab opened and so on. So is there an option to open bookmarks in background tabs? How can I achieve that?

Hi, everyone! I found a similar solution but only for "Open link in new tab": you can go to '''about:config''' and change the preference named '''browser.tabs.loadBookmarksInBackground'''. But I want the same thing for my saved bookmarks on '''Bookmarks Toolbar'''. Sometimes I need to open a few bookmarks from one folder and then I used for it middle-click or click on '''Open in new tab''', but it switches to tab immediately and I should repeat a process again: click on a folder, find a bookmark, click on it, new tab opened and so on. So is there an option to open bookmarks in background tabs? How can I achieve that?

被選擇的解決方法

Works for me. Bookmarks should open in the background if you have set browser.tabs.loadBookmarksInBackground = true Open links in a new tab in the background should be about browser.tabs.loadInBackground (normal links) and possibly browser.tabs.loadDivertedInBackground.

Note that you also can set browser.bookmarks.openInTabClosesMenu = false to keep the folder open and open more bookmarks.


Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

從原來的回覆中察看解決方案 👍 1

所有回覆 (3)

more options

選擇的解決方法

Works for me. Bookmarks should open in the background if you have set browser.tabs.loadBookmarksInBackground = true Open links in a new tab in the background should be about browser.tabs.loadInBackground (normal links) and possibly browser.tabs.loadDivertedInBackground.

Note that you also can set browser.bookmarks.openInTabClosesMenu = false to keep the folder open and open more bookmarks.


Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

more options

cor-el said

Works for me. Bookmarks should open in the background if you have set browser.tabs.loadBookmarksInBackground = true Open links in a new tab in the background should be about browser.tabs.loadInBackground (normal links) and possibly browser.tabs.loadDivertedInBackground. Note that you also can set browser.bookmarks.openInTabClosesMenu = false to keep the folder open and open more bookmarks.

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Thank you very much! It works as I wanted. Also it seems like there are two options browser.tabs.loadbookmarksinbackground and browser.tabs.loadBookmarksInBackground, the second one caused bookmarks opening in background. An option browser.bookmarks.openInTabClosesMenu works as well.

由 Maksym Pletiuk 於 修改

more options

You probably created browser.tabs.loadbookmarksinbackground yourself (pref names are case sensitive). You can click the trashcan icon next to this pref to remove this pref.