搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 83 will not open local webserver site - other browsers will

  • 4 回覆
  • 1 有這個問題
  • 103 次檢視
  • 最近回覆由 gabhan

more options

Since updating to Firefox 83 today, Firefox will not open my local webserver by name (anfield). I can ping the name of the server and it resolves fine. And the site opens correctly in Microsoft Edge. But Firefox just says 'Hmm. We’re having trouble finding that site. We can’t connect to the server at anfield.' Interestingly, I can open the website using it's IP address, but all my shortcuts to my development sites are on this webserver by name (anfield). Why is Firefox unable to resolve the name?

Since updating to Firefox 83 today, Firefox will not open my local webserver by name (anfield). I can ping the name of the server and it resolves fine. And the site opens correctly in Microsoft Edge. But Firefox just says 'Hmm. We’re having trouble finding that site. We can’t connect to the server at anfield.' Interestingly, I can open the website using it's IP address, but all my shortcuts to my development sites are on this webserver by name (anfield). Why is Firefox unable to resolve the name?

被選擇的解決方法

interestingly, adding .local works. And changing the network.dns.dns_query_single_label to false, also works without adding the .local. Cheers

從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options

I should add that I'm using Windows 10 and Firefox 83.0 (64-bit)

more options

hi, can you try to add ".local" at the end of the server name and see if you can connect then?

more options

You also could try this preference flip, which rolls back a change to how Firefox queries Windows DNS:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste dns_ and pause while the list is filtered

(3) Double-click the network.dns.dns_query_single_label preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox. Source: bug 1677806.

more options

選擇的解決方法

interestingly, adding .local works. And changing the network.dns.dns_query_single_label to false, also works without adding the .local. Cheers