搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Problem with encoding

more options

Hi there, I have a new computer working under Ubuntu. When using Firefox I often have a problem with the characters which appear when I open webpages or even read pdf documents. This isssue does not seem to happen in a very consistent way (some websites will appear correctly one day and incorrectly another day). I include below a screenshot as example. The problem does not seem to appear with chromium... If you have any idea about how to fix this I would be very grateful Thanks Michael

附加的畫面擷圖

被選擇的解決方法

As a test you can try to disable the Italic style for this element.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

Hi Michael, for the photo caption, when I check the site, it says the photo caption is Arial Bold Italic. Could you compare on yours using the Page Inspector tool:

  • right-click the unicode boxes and choose Inspect Element
  • after Firefox opens the Inspector, on the right side, change from the displayed panel to the Fonts panel (you may need to use a little triangle at the end of the bar that says Rules Layout Computed Changes Fonts Animations)

Here Firefox should show what the page calls for and what Firefox is actually using for that element.

有幫助嗎?

more options

選擇的解決方法

As a test you can try to disable the Italic style for this element.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

有幫助嗎?

more options

Hi, thanks for your answers. When I disable the italic on the element it appears correctly. How can I globally disable the use of italic with Firefox?

有幫助嗎?

more options

Disabling Italic was merely meant as a test.

We have seen cases where Firefox tries to use the Twemoji font that only includes emojis and not normal ASCII characters for displaying Italic text.

Is this happening in your case as well if you check the font that is used in the Font tab in the Inspector like suggested above ?


由 cor-el 於 修改

有幫助嗎?

more options

yes, this seems to be indeed the problem (Firefox using Twemoji font). From your answers on the other threads, do I interpret correctly that there is no known fix to this issue? thanks again for your help!

有幫助嗎?

more options

You can try to set gfx.e10s.font-list.shared = false on the about:config page.

有幫助嗎?

more options

unfortunately it was already set to false

有幫助嗎?

more options

PS tried to changed it to true and it did not change anything...

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題