搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Add-ons not showing in toolbar

  • 6 回覆
  • 4 有這個問題
  • 72 次檢視
  • 最近回覆由 Wavetrain

more options

Hello


When it comes to add-ons, then I add three of four at once or the same purpose, I try them all out, decide if I want to keep any of them, and then remove the ones I see that do not serve my target. All normal.


I know that it requires permission in order to have an add-on show in Private Browsing, that's done.

Now I had 8 add-ons on the toolbar, I disabled two or three of them so I can try two new ones. I did not like the new ones, so I just enabled the ones I had disabled, which where previously showing in the toolbar, all of this in Private Browsing having the permission of showing them.


As I enabled the add-ons again, they are not showing anymore in the toolbar..!!

Okay, I removed them and re-added them..not showing. I also did: not allow in Private Mode, then re-allowed..not showing. I simply restarted the browser in both normal and Private Mode, and yet not showing.. I also restarted my pc, and retried all previous steps again

  • This mainly happened as I removed the extension from toolbar, then added it again.

Still also 90% of the time, just disable then enable again, and only a few are showing again. Either when disabled then re-enabled or when removed then re-added*


So, what to do ?

所有回覆 (6)

more options

At the far right of the toolbar, do you see an arrow? Press it.

有幫助嗎?

more options

Hmm, I think you mean the double arrow to the right side.

I found it as I clicked on customize toolbar, when I hover it says [more tools..]. I found that add-on included in the list and dragged it to the toolbar. So, basically my problem is solved. But now I would like to know how to add those arrows please, if you may know how.

有幫助嗎?

more options

You can try Restore Defaults in customize mode or possibly reset browser.uiCustomization.state on the about:config page to see if that has effect.

由 cor-el 於 修改

有幫助嗎?

more options

Basically, the toolbar only has so much room. So any that can't be placed on the 'visible' bar is placed in the overflow area. (The double arrows.)

You can set up the icons to your liking.

有幫助嗎?

more options

Basically since I have access to the add-on again, then I take this problem as solved. Thank you everyone for your replies !

Just as comments on latest replies:

cor-el said

You can try Restore Defaults in customize mode or possibly reset browser.uiCustomization.state on the about:config page to see if that has effect.

I had restarted the customize page to default, I will try the about:config, but it seems that my default system does not have the overflow area or those double arrows displayed.

FredMcD said

Basically, the toolbar only has so much room. So any that can't be placed on the 'visible' bar is placed in the overflow area. (The double arrows.) You can set up the icons to your liking.

Sure, it seems that I will be going to the customize page every time I want to access the overflow area. At least in a way I know where the solution lies.

有幫助嗎?

more options

This problem is not solved for me and many others. None of the add-ons show on the toolbar or the overflow area. I have tried all the various suggestions as well as a complete uninstall and reinstall. For a while the add-ons showed up but when I finished doing all my selctions for privacy etc I noticed they were gone. Very disapointing as I will have to remove and use brave instead. It's interesting that just about EVERY new program version or even minor update that I've received for 2020 has resulted in either a problem or a less useful program. I also find that the support is lacking for finding a resolution as in this case.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題