Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Window position is shifted after maximize then unmaximize only when touching top edge of desktop

  • 4 回覆
  • 1 有這個問題
  • 24 次檢視
  • 最近回覆由 edata

more options

The position of the Firefox window is not restored correctly after clicking maximize then unmaximize (aka restore).

This is not a new problem. I think has always occurred on this machine (about a year old, Linux, Mint 19, Cinnamon).

It only happens if the window is touching the top edge (or corner) of the desktop. The unmaximized window is shifted down and to the right of the original position.

The window features (buttons, menus, etc) seem to return to their original positions, but the displayed window is shifted. For example, if I try to click the maximize button again, the mouse pointer needs to be above and left of the visible button.

I have turned off Linux desktop features, including window tiling and snapping, edge resistance, and some others, but I see no change. I also tried the monitor resolution and different desktop themes.

If this is not a bug, I am hoping I can disable something so that the window returns to its original position after it is unmaximized. For example, the height of the top border decreases when the window is maximized and increases when unmaximized, so if this is causing the issue, I am happy to disable it.

In the attached images, the top right of the image is the top right of the desktop. The first image shows Firefox in the top right corner before maximizing the window, and the second image shows the shifted position after unmaximizing the window. The expected behavior is for the window to return to the original position as shown in the first image.

Thanks for any help.

附加的畫面擷圖

All Replies (4)

more options

Hello edata,

Follow the steps i hope resolve your problem :

You can use one of these to leave Full Screen mode:

  • press the F11 key.
  • click the Maximize button at the right end of the Tab bar.
  • click the Full Screen button in the "3-bar" menu button drop-down list.
  • right-click empty space on a toolbar and click "Exit Full Screen Mode"

I hope resolve your problem then reply me back.


Thank you

Helpful?

more options

Full-screen mode does not have the bug I am describing, so that is a smart alternative. However, I do not want full-screen mode because I cannot see the tabs, address bar, etc. I want to maximize and unmaximize the window and have it return to the unmaximized position.

Thanks for your response though.

Helpful?

more options

I think that you need to take this to the support website of your Linux distribution.

Helpful?

more options

Thanks. I'm happy to try Linux support, but this only happens with Firefox. Can you explain why it would not be a Firefox issue?

Helpful?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題