搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How can I tell if iCloud.com does not allow for passwords to be saved in FF, for security reasons?

  • 10 回覆
  • 2 有這個問題
  • 57 次檢視
  • 最近回覆由 cor-el

more options

How can I tell if iCloud.com does not allow for passwords to be saved in FF, for security reasons? . . . I think this must be the reason . . . I'm using the latest, up-to-date versions, of Win 10 and FF

https://www.icloud.com/

Usernames and passwords are not saved . . . https://support.mozilla.org/en-US/kb/usernames-and-passwords-are-not-saved

Websites prohibit password saving

Some websites do not allow for passwords to be saved for security reasons. If you have followed the steps above, but are still not prompted to save a password when logging in to a certain website, that site may have disabled password saving.

被選擇的解決方法

Create New Login . . . https://www.icloud.com/ . . . ID . . . PW

I then go to . . . https://www.icloud.com/ . . . and nothing, no change . . . I right-click the Login cell / Fill Login / View Saved Logins / No logins found . . . but on the next page, it shows me this in the cell in the top center . . . idmsa.apple.com . . . that's obviously related . . . what if I put that in where I put the web page URL?

It won't let me modify the icloud URL, even if I click "Edit", so I click "Remove, then:

Create New Login . . . https://idmsa.apple.com . . . ID . . . PW

I then go back to www.icloud.com . . . and it works . . . what's going on here?

And, why don't line breaks work on this page

Auto-fill works on this page also, no extra login needed . . . https://appleid.apple.com/

從原來的回覆中察看解決方案 👍 0

所有回覆 (10)

more options

There are some web pages that do not allow browsers to record or fill in the log-in information.

But if you go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) you can try a Form Filling add-on. I found that the form-filler add-on I use is not affected.

有幫助嗎?

more options

Thx! Which form filler are you using that works with iCloud?

Maybe I could just import the Firefox data to that, and then disable the Firefox form filler?

有幫助嗎?

more options

I don't use iCloud. Just pick a form filler. If it doesn't work, try another.

Form fillers look for any input boxes, and fills them with the data you entered.
They can be set for all web pages (for example your name, address . . . .).
Orr they can be set for specific web sites.

有幫助嗎?

more options

. . . just try form fillers at random ?

. . . I use the Firefox form filler for everything, except banking and credit cards . . . I like using it . . . it seems to work for everything I do, except iCloud . . . so, what could be keeping it from working there?

. . . need a "spec" based way to determine what will work . . . some programming thing is going on . . . how do I figure that out?

有幫助嗎?

more options

You can post your question in the add-ons forum; https://discourse.mozilla-community.org/c/add-ons

有幫助嗎?

more options

Firefox doesn't honor autocomplete=off for quite some time and websites can't normally prevent Firefox from storing a login. If this doesn't work then first make sure you do not use Private Browsing mode. Some websites are coded in a way that Firefox doesn't detect the login form and in that case you can consider to create a new login in Lockwise (button at bottom of left panel) and save the username and password that way. You may have to use "Fill Login" and "Fill Password" in the right-click context menu or even paste username and password from the about:logins page.

有幫助嗎?

more options

選擇的解決方法

Create New Login . . . https://www.icloud.com/ . . . ID . . . PW

I then go to . . . https://www.icloud.com/ . . . and nothing, no change . . . I right-click the Login cell / Fill Login / View Saved Logins / No logins found . . . but on the next page, it shows me this in the cell in the top center . . . idmsa.apple.com . . . that's obviously related . . . what if I put that in where I put the web page URL?

It won't let me modify the icloud URL, even if I click "Edit", so I click "Remove, then:

Create New Login . . . https://idmsa.apple.com . . . ID . . . PW

I then go back to www.icloud.com . . . and it works . . . what's going on here?

And, why don't line breaks work on this page

Auto-fill works on this page also, no extra login needed . . . https://appleid.apple.com/

由 sludge7051-x 於 修改

有幫助嗎?

more options

The login form is in an iframe as you can see if you right-click the Apple ID field (This Frame -> View Frame Info), so you need to create the login for this https://idmsa.apple.com domain.

You can remove the icloud entry you made.

有幫助嗎?

more options

cor-el . . . You helped me to stumble upon the answer . . . Many Thanks!!

有幫助嗎?

more options

You're welcome.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題