搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How can I prevent ctrl+q from closing the browser?

  • 4 回覆
  • 1 有這個問題
  • 1080 次檢視
  • 最近回覆由 cor-el

more options

When I click ctrl+q by mistake, the browser window with all its tabs is closed immediately, with no warning. This has already made me lose data. is there a way to disable this keyboard shortcut?

When I click ctrl+q by mistake, the browser window with all its tabs is closed immediately, with no warning. This has already made me lose data. is there a way to disable this keyboard shortcut?

被選擇的解決方法

Hello, Could you please type about:config in the address bar

search for those two preferences and set them true: browser.sessionstore.warnOnQuit browser.warnOnQuit

Hope it will work out

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

選擇的解決方法

Hello, Could you please type about:config in the address bar

search for those two preferences and set them true: browser.sessionstore.warnOnQuit browser.warnOnQuit

Hope it will work out

more options

This solved the problem, thanks

more options

Note that there is also a checkbox in "Options/Preferences -> General -> Startup" for the fist pref.

  • Warn you when quitting the browser
more options

Firefox 87+ versions have a pref to disable Ctrl+Q to close Firefox. browser.quitShortcut.disabled = true You need to close and restart Firefox after toggling this pref.