搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

CTV.ca part of the web site doesn't display

  • 11 回覆
  • 1 有這個問題
  • 153 次檢視
  • 最近回覆由 RobertJ

more options

If I place the site "https://www.ctv.ca/Full-Episodes/A-Z" which is a local TV site FF 72.02 on a Mac does not display the channels. all add-ons where turned off and another browser on the same machine disaplyed the channels.

This appears to be a problem?

被選擇的解決方法

In a default Profile, with Standard tracking protection and no add-ons, the site loads fine.

You will need to forfeit some of your Privacy & Security to be able to see what's on TV.

從原來的回覆中察看解決方案 👍 1

所有回覆 (11)

more options

Hi Mace2, A visit to the site is pretty much a blank page for me. There are a lot of trackers being blocked. You'll need to allow all of that if you want to see what's there.

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked.

more options

Robertj I have Safari on the same machine which works and shows properly.

Cor-el I have disabled the add-on through FF and the results are the same.

more options

Disable any suspected add-ons and restart Firefox.

Also, check that Enhanced Tracking Protection is not blocking content.

more options

Hi Mace2,

I'm also on macOS, and I was able to reproduce the issue for you, as well as find the solution. The help you've been given has been on the right track.

The cause of the issue is (aside from CTV website developers) is the Disconnect add-on. Once disabled, you will need to force Firefox to bypass the cache when reloading the page to see the change take effect.

After you have disabled Disconnect, go to the webpage and hold the Shift key as you click the Reload button.

SIDE NOTE: Back in 2016, when Flash was on it's deathbed, I wanted to avoid sites that use it. With so many sites having already switched to HTML5, CTV was probably the last holdout. When I contacted them, they said they had no plans to switch to HTML5. Obviously, they have now switched, because every modern browser has removed Flash support. But that experience as well as this issue raise red flags about using the site. Here's a link to my blog post about it: https://ilias.ca/blog/2016/01/do-you-need-to-install-flash-anymore/

more options

Note that setting Flash to "Never Activate" is probably better than using "Ask to Activate" because the latter can cause issues with scripts that detect Flash is available, but Firefox may not prompt to activate or try to use Flash. With "Never Activate" the website can't detect Flash at all and will usually switch to the HTML5 media player.

more options

I am not using flash.

Also Android firefox works for this site.

more options

選擇的解決方法

In a default Profile, with Standard tracking protection and no add-ons, the site loads fine.

You will need to forfeit some of your Privacy & Security to be able to see what's on TV.

more options

Hi Mace2, Here's step-by-step instructions to fix the issue:

  1. Go to https://www.ctv.ca/Full-Episodes/A-Z
  2. On your Firefox toolbar, click on the Disconnect icon (or View and Manage Requests).
  3. Click Whitelist site.

I've created a video of me showing the fix:

more options

RobertJ you are correct. The privacy setting for enabling tracking specificaly "tracking content"

Once I disable that item it worked.

Thanks.

more options

If you changed Tracking Content to Only In Private Windows or disabled it completely that will affect all of the sites that you visit.

You might be better off to set that back to In All Windows, then, visit the site and click on the shield icon on your address bar. You can disable Enhanced Tracking Protection for only that site.

(when I visited the site there didn't appear to be any "malicious" content)