X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox seems to be breaking my html code

已張貼

hello -

I have the following HTML:

<a class='login' href='https://mydomain.com/'>

<img width='200' height='50' src='https://developers.google.com/identity/images/btn_google_signin_dark_normal_web.png' alt='Login Logo' /> <!--notice trailing space character and forward-slash character-->

</a>

This works fine in Chrome, but in Firefox 68.0.1, the trailing space and the slash character between the last single quote and the close-arrow character of the tag is being eliminated when the page loads, so the HTML looks more like this:

.............._normal_web.png' alt='Login Logo' ></a>

and the image is not loading, and instead, the "alt" text appears instead.

However, when i RIGHT_CLICK it, select "Inspect element" and "Edit HTML", then and add the space and forward-slack back in the code, then it looks fine.

Does anybody have any thoughts why firefox might be eliminating the space and forward-slash character? is there an easy workaround?

Here is the URL that is failing: https://comptonpeslonline.com/assignments/

hello - I have the following HTML: &lt;a class='login' href='https://mydomain.com/'> &lt;img width='200' height='50' src='https://developers.google.com/identity/images/btn_google_signin_dark_normal_web.png' alt='Login Logo' />&nbsp;&lt;!--notice trailing space character and forward-slash character--> &lt;/a> This works fine in Chrome, but in Firefox 68.0.1, the trailing space and the slash character between the last single quote and the close-arrow character of the <img> tag is being eliminated when the page loads, so the HTML looks more like this: .............._normal_web.png' alt='Login Logo' ></a> and the image is not loading, and instead, the "alt" text appears instead. However, when i RIGHT_CLICK it, select "Inspect element" and "Edit HTML", then and add the space and forward-slack back in the code, then it looks fine. Does anybody have any thoughts why firefox might be eliminating the space and forward-slash character? is there an easy workaround? Here is the URL that is failing: https://comptonpeslonline.com/assignments/

由 edwardsmarkf 於 修改

被選擇的解決方法

never mind, fixed it with css, but it still seemed pretty odd....

i figure it works in chrome, it should work the same in firefox.

從原來的回覆中察看解決方案 0
引用

額外的系統細節

已安裝的外掛程式

none i tried this in various OS's in browserstack.com as well - including version 69 - same problem.

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.142 Safari/537.36

更多資訊

提出問題者

<deleted>

<deleted>

由 edwardsmarkf 於 修改

這篇文章有幫助嗎?
引用

選擇的解決方法

never mind, fixed it with css, but it still seemed pretty odd....

i figure it works in chrome, it should work the same in firefox.

never mind, fixed it with css, but it still seemed pretty odd.... i figure it works in chrome, it should work the same in firefox.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題